Re: [greenstone-users] The incremental build doesn't working with GreenStone 2.7 in SuSE 10.1

From Michael Dewsnip
DateFri, 16 Jun 2006 15:51:58 +1200
Subject Re: [greenstone-users] The incremental build doesn't working with GreenStone 2.7 in SuSE 10.1
In-Reply-To (f24fc9c0606080132k2f9140daj82b742d3f751c081-mail-gmail-com)
Hi 王 鹏辉,

The "incremental build" option on the Create pane is extremely badly named. The idea is that if you haven't added any new files or changed metadata or plugin options, the importing process is unnecessary and can be skipped. I'm not sure how reliable this is -- personally I never use the option.

Eventually we will have true incremental building using Lucene, but that isn't ready yet. From the command line you can do incremental importing by putting just the new documents in the import directory and specifying the "-keepold" option to import.pl. Typically you need to do a complete buildcol.pl, however.

Regards,

Michael



王 鹏辉 wrote:
Hello, list,
I have installed the lastest version of GreenStone 2.7 in a SuSE 10.1 box. The java virutal machine is sun 1.4.2 version.
In the GLI, if i import a single document to a existing collection which contained many documents builded, it will rebuild all the documents index. It will cost so many time to build the existed index. So i want to use the incremental build instead of the full build. In the "Build" Tab of GLI, this is a radio selection, i have clicked "Incremental build", but i found that it alse do a full build.  The "Incremental Build" seems take no effect.

What did i missed or is there any other notice i have not paid attention to?

Best Regards

Wang Penghui

--
Wang Penghui
+86 592 8389 650

_______________________________________________ greenstone-users mailing list greenstone-users@list.scms.waikato.ac.nz https://list.scms.waikato.ac.nz/mailman/listinfo/greenstone-users