Re: [greenstone-users] compiling GLI

From Katherine Don
DateWed, 17 Sep 2003 16:45:08 -0600
Subject Re: [greenstone-users] compiling GLI
In-Reply-To (3F68D172-EC79C7A0-cs-waikato-ac-nz)

actually I have had the same problem. the test in for the java version:

javacOK=`$javacpath -target 1.4 2>&1`
if [ ! "$javacOK" = "" ]; then
    echo "The version of the Java Development Kit you have installed is too old"
    echo "to compile the Greenstone Librarian Interface. Please install a new"
    echo "version of the Java SDK (version 1.4 or newer) and rerun this script."
    exit 1
doesn't work for version  1.4.2. so just comment it all out. as long as you are using 1.4 or greater, then you will be ok.

hope this helps.

Michael Dewsnip wrote:
Hello Xaquin,

Before the script checks the version of the Java compiler, it displays the path
of the file it is checking, like:

Checking javac: /usr/local/bin/javac

You should check that the path displayed for you is correct.

Also, there are two different error messages. One says that it "failed to
locate an appropriate version of Javac", the other says that "the version of
the JDK you have installed is too old to compile the GLI". Which one do you


Michael wrote:


I'm having troubles to compile the Librarian.
After downloading gli from cvs I run and the result is a message
informing me that I need a java version 1.4 or newer.
The environment variable JAVAHOME is correctly set to java directory.
My sistem is a Mandrake 9.0 with Sun java sdk 1.4.2.
In this sistem Greenstone compiles fine.



Xaquin Lores

Correo enviado usando el servicio de Webmail del SIAIN:

greenstone-users mailing list

greenstone-users mailing list