Re: [greenstone-users] style:footer

From Oran Fry
DateFri, 22 Jun 2007 09:45:21 +1200
Subject Re: [greenstone-users] style:footer
In-Reply-To (004b01c7b37c$fbb72970$7cd36281-DJJSP581)
Hi Heather,

I gather you are your adding your footer text to the _footer_ macro in document.dm, as text there is automatically bolded. I was able to reproduce your problem with a collection of mine. I tried wrapping the footer text in various tags, and I tried modifying style.css  but to no avail - the text refused to unbold. Even replacing all instances of 'bold' with 'normal' in style.css did not work!

I found something that did work, though. It seems you need to add you text between the divs rather than within one of them. You also need a span wrapper like the one you tried.

Depending on you version of Greenstone your _footer_ macro might look a little different, but mine looked like:

_footer_ {
</div> <!-- document:footer -->
<div class="navarrowsbottom">
_navarrowsbottom_
</div>
_endspacer__htmlfooter_
}

And I modified it to look like:

_footer_ {
</div> <!-- document:footer -->
<span style="font-weight: normal;">some footer text</span>
<div class="navarrowsbottom">
_navarrowsbottom_
</div>
_endspacer__htmlfooter_
}

And that got me the text 'some footer text', in regular font weight, at the footer of each document.

This really shouldn't be so hard. I expect that this failure of css properties to properly style the footer is actually a result of bug in a greenstone macro somewhere. Until it's fixed I suggest just using the solution I have outlined. Customisation is going to be drastically improved for Greenstone3 soon, so keep an eye out for that.

Kind Regards,
Oran Fry.


Heather Rolen wrote:

Here’s something that is a little obscure to me- maybe the listserv can help.  I’ve searched in style.css and several of the macros but can not find where the footer is formatted so that I can remove the bold formatting.  I can add text to the footer, but can not *un-bold* the contents.  I’ve also tried </b> before the text, as well as <span style="font-weight:normal;"></span> but with no success.

 

Can someone point me to the appropriate macro, or encoding to change this setting?

 

Thanks!

Heather

 


_______________________________________________ greenstone-users mailing list greenstone-users@list.scms.waikato.ac.nz https://list.scms.waikato.ac.nz/mailman/listinfo/greenstone-users