Re: [greenstone-users] import.pl failed

From John R. McPherson
DateMon, 09 Feb 2004 15:00:10 +1300
Subject Re: [greenstone-users] import.pl failed
In-Reply-To (4026E567-5C163FD3-cs-waikato-ac-nz)
Katherine Don wrote:
> Hi
>
>>From a previous posting to the mailing list:
>
> Both our prebuilt linux and mac os x greenstone distributions were
> built
> on machines that use perl 5.6, and the distributions contain a few
> binary perl modules.
>
> Install the perl "XML::Parser" natively for your system and get
> greenstone to use that instead of the one that comes with
> greenstone.
> You might have to remove the "gsdl/perllib/cpan/XML" and
> "gsdl/perllib/cpan/auto" directories so that perl doesn't look in
> there
> first.

Just a note that the most recent version of our binary Mac OS X release
includes the module for both perl 5.6 and perl 5.8, and the install
script should (hopefully) install the correct one for your system.

> You can get expat from http://sourceforge.net/projects/expat/ and
> XML::Parser from http://search.cpan.org/~msergeant/XML-Parser-2.34/
> I think you need to install both of these.

If you are using linux, you are better off installing your
distribution's package of this: on debian, you want to install the
"libxml-parser-perl" package, and on redhat and mandrake it is called
"perl-XML-Parser". Not sure about other distributions.


John McPherson