Re: [greenstone-users] Display Collection ID in UI

From Richard Managh
DateTue, 31 Jan 2006 13:50:06 +1300
Subject Re: [greenstone-users] Display Collection ID in UI
In-Reply-To (F0C6542972BAEF43B2F44823C7F581B2010DA125-SMATHERS2K3EX-smatherslib-uflib-int)
Hi Mark,

[collection] was added in Greenstone 2.61 to get around a problem when
using cross-collection searching. It is set automatically by the
Greenstone run-time code. If you aren't using cross-collection searching
you should use _cgiargc_ instead, which will also give you the internal
collection name.

If you are using cross-collection searching then check you aren't using
[collection] outside a format statement. Otherwise, this could be a bug
(please send your format statement to the mailing list).

Hope this helps,

Richard.
--
DL Consulting
Greenstone Digital Library and Digitisation Specialists
contact@dlconsulting.co.nz
www.dlconsulting.co.nz


Mark Sullivan wrote:

> All,
>
> I am having problems getting the collection id to display on my
> collections. Where does the data for [collection] come from?
>
> I am not using the GLI, but building my collections outside in our own
> automation software. We produce the □doc.xml□ files in our code, and
> then call the □buildcol□ perl script. I looked in GLI-produced
> □doc.xml□ files, and the collection does not appear in them.
> Additionally, it doesn□t appear in the □collect.cfg□ file explicitly.
> Where does this data come from?
>
> Is this read in during Greenstone run-time from the □build.cfg□ file?
>
> Thank you for your help,
>
> Mark Sullivan
>
> Systems Programmer
>
> University of Florida Libraries
>
> Gainesville, FL, U.S.A.
>
>------------------------------------------------------------------------
>
>_______________________________________________
>greenstone-users mailing list
>greenstone-users@list.scms.waikato.ac.nz
>https://list.scms.waikato.ac.nz/mailman/listinfo/greenstone-users
>
>