RE: Building using -create_images gives error

From Jared Potter
DateFri, 22 Feb 2002 12:32:30 -0800
Subject RE: Building using -create_images gives error
I used CPAN to upgrade to the newest version, which is 1.211. I have looked
in the directory and tried to run the scripts, they don't even provide me
with usage information, just the error:

protocol error (1) at /usr/lib/perl5/site_perl/i386-linux/Gimp/ line

I have also tried running the other scripts the same way, and have gotten
the same error. I don't suppose your new scripts would work with 1.211
would they? or can you tell me how to fix this problem in the script itself.
I have a feeling it's being called by line 343:

Gimp::on_net { gsdl_flash_button; };

I'm not a perl guru, and havn't found anything in the perl documentation I
have lying around. Any help would be great!

Jared Potter
Mercy Corps

-----Original Message-----
From: Gordon Paynter []
Sent: Friday, February 22, 2002 11:21 AM
To: Jared Potter; Greenstone (E-mail)
Subject: Re: Building using -create_images gives error

On Friday 22 February 2002 10:36, Jared Potter wrote:
> Hello, when I execute the command:
> -create_images agency
> I get this error:
> protocol error (1) at /usr/lib/perl5/site_perl/i386-linux/Gimp/
> line 66.
> protocol error (1) at /usr/lib/perl5/site_perl/i386-linux/Gimp/
> line 66.
> Does anyone know what this is about? I have installed the Gimp perl
> modules.

I haven't used the -create_images flag, but I suspect the problem is
that the Greenstone scripts use Gimp 1.0 (or maybe 1.1) and you have
installed gimp version 1.2.

If you look in the $GSDLHOME/bin/script/gimp directory you'll find the
scripts that are utlimately called to create images. Can you run
these from the command-line? There may be gimp version 1.2 versions
in there also (I have some improved Gimp 1.2 scripts somewhere if
these don't work).