Re: [greenstone-devel] wget not found

From Michael Dewsnip
DateTue, 01 Mar 2005 17:17:17 +1300
Subject Re: [greenstone-devel] wget not found
In-Reply-To (OF09B6BF8A-E5544512-ON69256FB7-00147243-69256FB7-0014D7A3-nt-gov-au)
Hi Stephen,

If you run gli.sh from a shell you should be able to see any error
messages that occur.

Cheers,

Michael

Stephen.DeGabrielle@nt.gov.au wrote:

>
> Thanks guys,
> I will start off trying to make a /bin/linux directory and put wget in
> that - from what you said that should work
> unfortunately I deleted my greenstone install from the Applications
> folder and reinstalled it - and now gli wond start up at all - just a
> flash on the dock and it dissapears.
> I am reloading 2.52 from the site in an attempt to get GLI going
> again. If that fails I'll try CVS.
>
> s.
>
>
> ----------
> Stephen De Gabrielle
> 8922 0887
>
> I'm sick of the Internet - I want a yabby net.
>
>
>
>
>
> *Michael Dewsnip <mdewsnip@cs.waikato.ac.nz>*
> Sent by: greenstone-devel-bounces@list.scms.waikato.ac.nz
>
> 01/03/2005 07:12 AM
>
>
> To: Russell Sheptak <rus@sonic.net>,
> stephen.degabrielle@bigpond.com
> cc: greenstone-devel@list.scms.waikato.ac.nz
> Subject: Re: [greenstone-devel] wget not found
>
>
>
>
> Hi Russell,
>
> Thanks very much for pointing this out -- I've fixed it in CVS. Turns
> out there was another problem which caused the manually set wgetpath in
> the gli.sh file to be ignored (which is why setting this didn't work for
> you, Stephen); I've fixed this also.
>
> Cheers,
>
> Michael
>
>
>
> Russell Sheptak wrote:
>
> > There's a bug in the code in gli's Utility.java in the 2.52 sources.
> > The author of the method that generates the path used to find the wget
> > utility assumed that both the macintosh and linux would look for
> > binaries in the $GSDLHOME/bin/linux directory. Of course it really
> > needs to be looking for wget in the $GSDLHOME/bin/darwin directory, as
> > shipped.
> >
> > I can send you either a corrected GLI.jar to drop into you
> > installation (assuming you're not building from source) or a corrected
> > Utility.java if you want to rebuild GLI from source. Let me know
> > which you want.
> >
> > rus
> >
> > On Feb 28, 2005, at 6:18 AM, stephen.degabrielle@bigpond.com wrote:
> >
> >> Hi. I just downloaded the latest gs for os x 10.3.
> >> Unfortunately, the GLI reports that it can't find a suitable wget and
> >> is disabling the web page download.
> >>
> >> I have checked it is included-Which it is- and even changed gli.sh to
> >> point to it in the applications/Greenstone/bin/Darwin folder to no
> >> avail.
> >>
> >> Has anyone else had this problem? I'm [easily] stumped.
> >>
> >> Regards,
> >>
> >> Stephen
> >>
> >> --
> >> Stephen De Gabrielle
> >> 0404041209 sms/mms
> >>
> >>
> >> _______________________________________________
> >> greenstone-devel mailing list
> >> greenstone-devel@list.scms.waikato.ac.nz
> >> https://list.scms.waikato.ac.nz/mailman/listinfo/greenstone-devel
> >>
> >>
> > ----------------------
> > Rus Sheptak rus@sonic.net
> >
> >
> > _______________________________________________
> > greenstone-devel mailing list
> > greenstone-devel@list.scms.waikato.ac.nz
> > https://list.scms.waikato.ac.nz/mailman/listinfo/greenstone-devel
> >
>
>
> _______________________________________________
> greenstone-devel mailing list
> greenstone-devel@list.scms.waikato.ac.nz
> https://list.scms.waikato.ac.nz/mailman/listinfo/greenstone-devel
>
>
>