Re: [greenstone-users] problems with importing/building

From Michael Dewsnip
DateThu, 26 Jan 2006 17:06:31 +1300
Subject Re: [greenstone-users] problems with importing/building
In-Reply-To (Pine-LNX-4-43-0601241403190-2634-hymn05-u-washington-edu)
Hi,

XML::Parser has given us a lot of trouble, unfortunately (although to be
fair, we shouldn't be trying to distribute it in built form). There is
an FAQ entry concerning XML::Parser problems at
http://www.greenstone.org/cgi-bin/library?a=p&p=faqbuild#33. I suggest
you try renaming the
/home/agent/apache2/htdocs/gsdl/perllib/cpan/perl-5.8/auto/XML directory
to something like
/home/agent/apache2/htdocs/gsdl/perllib/cpan/perl-5.8/auto/XML.tmp, just
to see if you already have the XML::Parser modules installed with your
Perl. If that fails, you'll need to install the XML::Parser modules as
described in the FAQ entry.

The "No plugin expected to process file" errors in the GLI will be
caused by the XML::Parser problem. Once you've got XML::Parser working,
delete the ~/.gli/classifiers.dat and ~/.gli/plugins.dat files and rerun
the GLI.

Regards,

Michael

agent@u.washington.edu wrote:

>
> Hello all,
>
> I recently installed Greenstone (on Linux) and have tried building a
> test collection using both the command line and GLI. Both times, I get
> the same problem when running the import.pl to build the collection.
>
> When using the GLI, I first get a "No plugin expected to process file"
> dialog box to show up when I try dragging and dropping new files under
> the Gather tab. This happens regardless of the file type (gif, html,
> pdf) even though the Design tab indicates that I have those plugins.
> Do I need to somehow configure each plugin?
>
> When I try to build the collection from the Create tab, or try to run
> import.pl from the command line, I get the following output:
>
> Command: /home/agent/apache2/htdocs/gsdl/bin/script/import.pl -gli
> -language en -collectdir /home/agent/apache2/htdocs/gsdl/collect/
> -removeold testcoll import.pl> Can't load
> '/home/agent/apache2/htdocs/gsdl/perllib/cpan/perl-5.8/auto/XML/Parser/Expat/Expat.so'
> for module XML::Parser::Expat:
> /home/agent/apache2/htdocs/gsdl/perllib/cpan/perl-5.8/auto/XML/Parser/Expat/Expat.so:
> undefined symbol: PL_sv_undef at /usr/lib/perl/5.8/DynaLoader.pm line
> 225.
> import.pl> at
> /home/agent/apache2/htdocs/gsdl/perllib/cpan/perl-5.8/XML/Parser.pm
> line 14
> import.pl> Compilation failed in require at
> /home/agent/apache2/htdocs/gsdl/perllib/cpan/perl-5.8/XML/Parser.pm
> line 14.
> import.pl> BEGIN failed--compilation aborted at
> /home/agent/apache2/htdocs/gsdl/perllib/cpan/perl-5.8/XML/Parser.pm
> line 18.
> import.pl> Compilation failed in require at
> /home/agent/apache2/htdocs/gsdl/perllib/XMLParser.pm line 30.
> import.pl> BEGIN failed--compilation aborted at
> /home/agent/apache2/htdocs/gsdl/perllib/XMLParser.pm line 30.
> import.pl> Compilation failed in require at
> /home/agent/apache2/htdocs/gsdl/perllib/plugins/XMLPlug.pm line 38.
> import.pl> BEGIN failed--compilation aborted at
> /home/agent/apache2/htdocs/gsdl/perllib/plugins/XMLPlug.pm line 38.
> import.pl> Compilation failed in require at
> /home/agent/apache2/htdocs/gsdl/perllib/plugins/GAPlug.pm line 33.
> import.pl> BEGIN failed--compilation aborted at
> /home/agent/apache2/htdocs/gsdl/perllib/plugins/GAPlug.pm line 33.
> import.pl> Compilation failed in require at
> /home/agent/apache2/htdocs/gsdl/perllib/plugin.pm line 95.
> import.pl> Command failed.
>
>
> I suspect that I'm making some sort of newbie mistake somewhere. If
> someone can tell me what is going wrong, I'd certainly appreciate it.
> Thanks in advance.
>
> Cheers,
> /tom
>
>