[greenstone-users] after build or rebuild collection - must restart server to see?

From Michael Pelikan
DateTue, 24 Feb 2004 15:33:39 -0500
Subject [greenstone-users] after build or rebuild collection - must restart server to see?
Hello -

We've been making progress working from the command line. Our as-yet
imperfectly formed collections (our fault, not Greenstone's) are making it
through the process as described. We look forward next to tackling
PagedImg plugin.

At this point in our testing and wringing-out phase, we're still running
the Local Library on our test server.

The current wrinkle we're working on is this: after running import.pl and
buildcol.pl, either to create or modify a collection, and then after moving
the resulting files from the 'building' folder to the 'index' folder, the
collection either a) disappears from our GSDL collections page if it's an
existing collection or b) never appears on our GSDL collections page
- until we restart the server.

Is this the normal behavior? Is there something we can do besides
restarting the server to refresh the server's accounting of the collections
it is serving out? We've verified that this is not a 'refresh-the-browser'
issue.

Has anyone else run into this? Are we missing a perfectly obvious
command-line switch or something?

Many thanks -


Michael Pelikan
Technology Initiatives Librarian
Department for Information Technology (I-Tech)
University Libraries
Penn State University
102 Paterno Library
University Park, PA 16802-1808
(814) 865-5660
mpp10@psulias.psu.edu