[Fwd: Re: [greenstone-users] Generated URL problem]

From qq6@cs.waikato.ac.nz
DateTue Jan 22 16:24:43 2008
Subject [Fwd: Re: [greenstone-users] Generated URL problem]
In-Reply-To (47947F37-8010301-cefngwlad-org)
Hi Huw,

The URL of each document is stored at metadata ex.srclink. It is started
with macro /gsdl. And later on, /gsdl will be replaced with
a web home address when GSDL is loaded. For this reason, you can check
metadata ex.srclink value of the pdf document and compare it with the same
medatada value of the word document from the "Enrich" panel of GLI. If the
metadata value looks fine, you might have to look at format statement of
the collection to see whether any restriction has been set up when
displaying PDF documents, or send me the collect.cfg file if you like. I
can help you to look at it.

Regards
Quan

> Hi Quan,
>
> qq6@cs.waikato.ac.nz wrote:
>> Could you describe the problem more detail?
> I'll try! The server is running Fedora 8 and I'm using a web library
> (Greenstone v 2.80) running on Apache. Everything works fine until you
> click on a collection and start to browse the contents (using Titles).
> The text versions of documents are fine with the correct URL's being
> generated but the URL's for PDF documents seem to be missing a /gsdl at
> the beginning od the URL. This issue doesn't appear to affect Word
> documents which have the correct URL's generated for them.
>
> TIA
>
> Huw
>
>> Such as, which platform are you working on? Are you using the local
>> library or
>> web library?etc.
>>
>> Regards
>> Quan
>>
>>
>>
>>> Hi everyone,
>>>
>>> At long last (and with considerable thanks to George) I have Greenstone
>>> up and running properly. I am building a 'test' collection and am
>>> running into a strange issue - possibly a software bug. When I build a
>>> collection using PDF's everything is fine until I try to open the PDF
>>> files. I get this 404 error:
>>>
>>> The requested URL
>>> /collect/huw-adroddia/index/assoc/HASH019e.dir/doc.pdf
>>> was not found on this server.
>>>
>>> The problem is solved by manually inserting gsdl/ to the URL. i.e. The
>>> files are being created but the generated URL is missing a gsdl ! I've
>>> checked the config files and they look fine to me. Could this be a bug?
>>>
>>> TIA
>>>
>>> Huw
>>>
>>> --
>>> ================================
>>> Huw Wyn Jones
>>>%