Re: [greenstone-users] Re: Can't Load Document

From Rene Schrama
DateThu, 16 Oct 2003 10:04:25 +0200
Subject Re: [greenstone-users] Re: Can't Load Document
Hello Katherine,

Yes I was referring to the error messages. However, since I started
using the BibTex plugin they completely disappeared. Apparently, MGPP
and the HTML plugin are not happy together.

In the meantime, I found the cause of the other problem (search box
with strange caption appearing on About page after (re)build). I read
somewhere (forgot where) that when using MGPP the search box should not
be displayed on the About page. This is happening anyway because the cgi
arguments are wrong. The cgi args under the View Collection button, for
example, are (assuming the name of the collection is "soreme"):

a=p
p=about
c=soreme

The correct cgi args are:

site=localhost
a=p
p=about
c=soreme
ct=1
qto=3
qt=1
l=en
w=utf-8

I don't know which one is critical but you get the idea. Please note
that there is more than one way to get to the collection after a build,
so this will have to be fixed in several places. I hope this is making
sense but if you have more questions please let me know.

Regards,
Rene Schrama


>>> Katherine Don <kjdon@cs.waikato.ac.nz> 14-10-2003 22:21:14 >>>
hi Rene

what are you referring to in your two questions?
if you are talking about the mgpp_passes error messages, this is not
normal behaviour. if you rebuild your collection, do you still get these
errors?
if so, please send me (off the list) your config file (collect.cfg) and
a couple of documents so that I can have a look at it for you.

if your questions are not referring to the mgpp stuff, please clarify
what you mean.

regards,
Katherine Don.

Rene Schrama wrote:

> Solved both problems.
>
> Problem 1 (can't load document text): the key to the solution was in
the error message (document text = [Text]). Don't use the default
format, make your own and don't use [Text]. Export your database in
BibTex format instead of HTML. Btw there is no need to convert accented
characters to BibTex format because they don't cause any problems during
the import/build process. Use the config file from
http://www.cs.waikato.ac.nz/~ihw/greenstone/inside.htm (chapter 5.
Bibliography collection) as an example.
>
> Problem 2 (strange looking user interface after build): this is only
temporary. I clicked on Home and after that on the collection icon
(re-entered the collection) and all was fine.
>
> However, two questions remain:
>
> 1. Is this normal behaviour or a bug?
> 2. Do I have to worry about the error messages? As far as I can tell
everything seems to work OK now, even the [Text] index.
>
> Rene
>
> >>> "Rene Schrama" <Rene.Schrama@niwi.knaw.nl> 08-10-2003 15:29:30
>>>
> Hi,
>
> On July 31, Dave S wrote about the MGPP problem as stated below. Now
the same is happening to me. Has there been any progress in this matter?
I'm also using version 2.40 on Windows XP. Btw I couldn't get the user
interface to work with the Collector (only one search box, with the
following text above it: "Search for _idx_ which contain some|all of the
words") so I had to build it from the command line.
>
> Errors during build were:
>
> mgpp_passes.exe : Cannot open Sec
> mgpp_compression_dict.exe : Unable to open "D:Program
Filesgsdlcollectsoremebuilding extsoreme.tsd"
> mgpp_passes.exe : Cannot open Sec
>
> (the complete listing is quite large but I will be happy to provide
it)
>
> There were no errors during import, just some warnings about the
language defaulting to EN.
>
> Rene