[greenstone-users] problem launching GLI in Windows XP

From Jim Hart
DateWed Apr 28 02:34:00 2010
Subject [greenstone-users] problem launching GLI in Windows XP
In-Reply-To (FEA827C08D2D824CA8BD22534B1DD2BA25A79B3909-KENTS-MBX01-KENTS-LOCAL)
Dear Yin,

This is really odd as the exact same steps work fine for me under
Windows XP. So, I have a question and something to try.

First, what version of Greenstone gave the error in the screenshot you sent?

Second, if it is 2.83, please try entering the GLI command as:

C:Greenstsonegli>.gli

This will assure that the gli.bat in the current directory is being run,
not one that's somewhere else in the PATH.

Regards,
Jim Hart
Bates College

On 4/21/10 4:23 PM, ZHANG, YIN wrote:
> Anupama,
>
> Thanks so much for your reply. I followed your suggestion to completely uninstall Greenstone, then installed it under C: directly, but still experienced the same problem.
>
> I had received a very kind and experienced fellow listserv subscriber's help to check my PATH and even manually set the path in the setup.bat file, but the problem persists. I have also tried to run the setup.bat, dli.bat, and some other .bat files in the command mode, and received a common incomplete error message - please see the screenshots in the attached file. Hope it is helpful for troubleshooting.
>
> I have been teaching a digital library class using Greenstone in the past two years. It seems all fresh installations on windows are fine. It is very tricky to get Greenstone to work on a Mac. And, almost all reinstallations and upgrades of Greenstone are troublesome although we followed the Greenstone tutorials for uninstallations and upgrades.
>
> Thanks so much,
>
> Yin
>
>
> -----Original Message-----
> From: Anupama of Greenstone Team [mailto:greenstone_team@cs.waikato.ac.nz]
> Sent: Tuesday, April 20, 2010 12:20 AM
> To: ZHANG, YIN; greenstone-users@list.scms.waikato.ac.nz
> Subject: Re: [greenstone-users] problem launching GLI in Windows XP
>
> Hi Yin,
>
> I think this may be due to there being spaces in the filepath to your
> Greenstone installation. I have more recently found there were in fact
> still issues to do with this when running GLI.
> Could you try uninstalling and then reinstalling Greenstone 2.83
> somewhere else, in a location where there are no spaces in the filepath
> (no space characters in any of the parent directories containing your
> Greenstone2.83)?
>
> For example, if you have admin rights, try installing it into say
> C:yinGreenstone2.83.
>
> Does the problem you described persist after the reinstall?
>
> We have been looking at sorting out the larger problem of GLI dealing
> with spaces and intend on fixing it.
>
> Regards,
> Anupama
>
>
> ZHANG, YIN wrote:
>
>> Hi,
>>
>> Sorry if this has been answered before - I did search the listserv archives and found this question was asked a few times but I did not see a solution.
>>
>> I recently upgraded to 2.83 windows version of Greenstone and have problem to launch the Librarian Interface. I did uninstall the previous version and then install v2.83. When I try to launch the GLI from Start/Programs, a command prompt pops up for a second and then disappears. When I try to run gli.bat in the command mode, it only shows an incomplete copyright message that ends "was unexpected at this time."
>>
>> I have checked that both Perl and java are installed. Also, I have the admin rights to the computer, and checked the permissions of greenstone directory and ruled the permission issue out
>>
>> Any help would be really appreciated.
>>
>> Yin
>>
>>
>>
>> ------------------------------------------------------------------------
>>
>> _______________________________________________
>> greenstone-users mailing list
>> greenstone-users@list.scms.waikato.ac.nz
>> https://list.scms.waikato.ac.nz/mailman/listinfo/greenstone-users
>>
>>
>>
>> _______________________________________________
>> greenstone-users mailing list
>> greenstone-users@list.scms.waikato.ac.nz
>> https://list.scms.waikato.ac.nz/mailman/listinfo/greenstone-users
-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://list.scms.waikato.ac.nz/mailman/private/greenstone-users/attachments/20100427/41c450fc/attachment.html