Re: [greenstone-users] Error Message

From John R. McPherson
DateMon, 10 Nov 2003 10:41:30 +1300
Subject Re: [greenstone-users] Error Message
In-Reply-To (1FEDCC7B932B2C4ABBD003A2FF605D20035105B2-ctsinwcbsxud-cts-com)
Thiagarajan, Rajendran (Cognizant) wrote:
> hi all

Please do not send the same question multiple times via both the lists
and the web support form - it will not make any difference other than to
create extra work for us. We've asked you previously not to do this.

> i'm using greenstone 2.40a...and source data as PDF
>
> After building the collections, gli says, collection ready for
> preview...........but while i'm searching data in search index the
> following error message was produced "An error occurred during the
> construction of the cgi page.".....and also output was not displaying
> in the other index like subject, organization........i not able to
> find the reason, why these errors are occuring....
>
> please can any body send me, how to avoid these errors.

You will need to provide much more information than this if we are going
to be able to determine what is causing your problem.
Did your collection build successfully? Look in the collection's "etc"
directory. The file fail.log tells you if the plugins failed to convert
or import any documents. If you used The Collector, then there should
also be a "build.log" file with more debugging information in it.

What does the collection's "build.cfg" file in the "index" directory
say? Have you tried building the collection from the command line, since
this gives more informative warning/error messages?

What was the URL in your web browser that gave the error? What does
greenstone's "error.txt" file in the main "etc" directory have in it?
That should give us clues to any problems with your greenstone
setup/collections.

If you just say "it doesn't work, how do I fix it?" then there is no
chance of us being able to help you determine what the problem is.


John McPherson