[greenstone-users] Greenstone in Google Chrome and Apple Safari browsers

From Jay Clark
DateThu Aug 12 07:21:01 2010
Subject [greenstone-users] Greenstone in Google Chrome and Apple Safari browsers
In-Reply-To (4C61D736-4060006-cs-waikato-ac-nz)
Thank you Katherine for this information.
How long till these changes are available to download in a pre-compiled form? If that means waiting till the next release version of Greenstone, when do you anticipate that release?

Thanks,
~Jay

________________________________
From: Katherine Don [mailto:kjdon@cs.waikato.ac.nz]
Sent: Tuesday, August 10, 2010 4:48 PM
To: Jay Clark
Cc: greenstone-users@list.scms.waikato.ac.nz
Subject: Re: [greenstone-users] Greenstone in Google Chrome and Apple Safari browsers

Hi Jay

You are probably using the windows local library server on windows, not apache. Apache is set up to use the correct mime types, but it turns out the local library server program wasn't set up to handle css files properly.

Its a simple fix, but you'll need to recompile the code (which you'll need to download if you haven't already).
Have a look at
http://trac.greenstone.org/browser/main/trunk/greenstone2/runtime-src/src/w32server/cgiwrapper.cpp. If you click on last change near the top right, you can see the code that was added.

Alternatively, you could switch to using apache - you need to start greenstone using gs2-server.bat instead of from the start menu. If you are using GLI, then you'll also need to rename server.exe to something else, so that GLI knows you are using apache.
If gs2-server.bat doesn't work for you (which it apparently doesn't for a few people) then you can start apache with gsicontrol.bat instead, see http://wiki.greenstone.org/wiki/index.php/2.83_Release_Notes#Using_gsicontrol_script for more info.

Regards,
Katherine

Jay Clark wrote:
Hi,
Does anyone know why the default installation of Greenstone 2.83 doesn't work in Google Chrome and Apple Safari web browsers on Windows XP/7? When I look at my local library in either of these browsers, they don't use the external stylesheets (style.css, print-style.css).

After hours and hours of trying to figure out the issue, I think we narrowed it down to the installed Apache server (on Windows) failing to serve out the CSS files with the proper mime type. Unfortunately, I can't figure out why it's doing that, as the mime.types file in Apache's sub-folders is configured correctly (as far as my novice eyes can tell). When I install Greenstone 2.83 on my Macbook, Safari and Chrome have no issues displaying the page.

I also considered that it could have something to do with the file's encoding. On my Mac, the files are encoded as UTF-8, but on Windows, they're CP1252. I'm not experienced enough in mime-types and file encodings to know if this is part of the issue.

Has anyone else determined a fix for this issue?


Thank you,
Jay Clark

MAF Learning Technologies
www.maf.org<http://www.maf.org>
www.maflt.org<http://www.maflt.org>

________________________________

_______________________________________________
greenstone-users mailing list
greenstone-users@list.scms.waikato.ac.nz<mailto:greenstone-users@list.scms.waikato.ac.nz>
https://list.scms.waikato.ac.nz/mailman/listinfo/greenstone-users

-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://list.scms.waikato.ac.nz/mailman/private/greenstone-users/attachments/20100811/52e35f22/attachment.html