[greenstone-devel] PageImg collection display issue

From Beth Nicol
DateThu, 18 Nov 2004 11:10:57 -0600
Subject [greenstone-devel] PageImg collection display issue
I am building a collection using the PageImgPlug that contains page
images (jpegs) and the associated OCR's text. It builds beautifully as
far as I can tell. But, then I get into formatting issues for the pages:

Environment: GSDL 2.51, RedHat Linux Enterprise, binary install (Apache
1.3 server)

When I use the following format string, I get a nice display sized
image sitting alongside the full-OCR's text for the page.

format DocumentText "<center><table width=537><tr><td
valign="top">[srclink]View fullsize imag
e[/srclink]<br />{If}{[screenicon],[screenicon],'where is that
picture?'}</td><td valign="top">[Text]
</td></tr></table></center>"

However, when I use this format string and select the "small" view,
which is the one which I expect to replicated the format I have above, I
get a nice display sized image alongside only the OCR'd text for
perhaps the first line or first paragraph: (this format comes primarily
from the example in the plugin file itself)

format DocumentText "<center><table
width=537><tr><td><a href=_ht
tpdocument_&d=419CD7A1-302-bellsouth-net&p=small>Switch to small version.</a>,<a
href='/gsdlmod?e=d-00000-00---off-0gsarch--00-0----0-10-0---0---0direct-10---4-----dfr--0-1l--11-en-50---20-about-Harawira--00-0-1-00-0--4----0-0-11-10-0utfZz-8-00&a=d&d=419CD7A1-302-bellsouth-net&p=full'>Switch to fullsize
version</a>)<br /><a
href=/gsdlmod?e=d-00000-00---off-0gsarch--00-0----0-10-0---0---0direct-10---4-----dfr--0-1l--11-en-50---20-about-Harawira--00-0-1-00-0--4----0-0-11-10-0utfZz-8-00&a=d&d=419CD7A1-302-bellsouth-net&p=small title=View Image with
Text>[srcicon]</a></td></tr></table></center>"

I've looked at the source of the presented page, and sure enough - the
<pre> text starts - the </pre> tag is never closed, and the data is
nowhere to be found.

I've looked at the format line 'til I'm cross-eyed and I can't see
anything there, so my guess is that there might be a bug in the code
when the presentation (p=small) is invoked.

Help. Ideas? The collection is at
http://automation.lib.auburn.edu/gsdl/cgi-bin/library - it's the Auburn
Board of Trustees minutes - but I'm working with it, so no guarantees
that it will be set up to see the error at any given time!

--
peace,
beth
bethnicol@bellsouth.net