[greenstone-users] Can't see any file in library

From Greenstone Team
DateTue Jul 12 18:57:55 2011
Subject [greenstone-users] Can't see any file in library
In-Reply-To (CAKiObEabzgvtjvDHSjJinYyDBGy4+aB-F0tt-+kQXwFO+2gmig-mail-gmail-com)
Hi Farzaneh,

Did you by any chance have another Greenstone installation on your
machine (previously)? To avoid GLI getting confused between multiple
installations, try the following:

1. Open GLI, if it's not open. Then close any open collections. Quit GLI.
2. Since you're on Windows, use the Windows Start menu to run GLI again.
(Alternatively, you could open a fresh new DOS terminal to run GLI from.
there)
3. This time, try opening the Greenstone collection you were previously
working on. If you can't locate it in the current Greenstone's collect
directory (if your collection is not listed when you try File > Open in
GLI), then it was probably accidentally built in another location, which
could be why your collection didn't show up in the browser after building.
If you don't want to recreate your entire collection, then try to find
this collection inside the "collect" folder of any other Greenstone
installations you may have. If you have found it, use your File Browser
either copy or move it into the "collect" folder of the Greenstone
installation you wish to be working with (which should be the one you
ran GLI from just now).
4. Exit GLI.
5. Restart GLI.
6. If you copied any collections into your current Greenstone
installation in step 3, it should now appear when you try the File >
Open dialog in GLI.
7. Rebuild the opened collection.
8. Press the Preview button.

If the above does not answer your question and resolve the problem
you're faced with, please write back with more details of where and how
things are failing. For instance, when you wrote "but when go to library
(by clicking Preview button) I could not see any file", where there any
error messages displayed on the browser page when you pressed Preview?

For general information: the Greenstone binaries on the Snapshots are
not guaranteed to work. They are merely temporary builds of the current
code. To get a stable version of a Greenstone binary, try to download a
binary from http://www.greenstone.org/download

Regards,
Anupama


Farzaneh Ghayour wrote:
> Hi,
>
> I installed Greenstone 2
> downloaded from http://www.greenstone.org/snapshots
> Windows Binary Snapshot (2s2011.07.07
> <http://www.greenstone.org/release-snapshots/Greenstone-2s2011.07.07-windows.exe>,
>
> I created a new collection
> drag files to it
> set metadata from Enrich tab
> and set browsing from Design tab ( fields are the ones I set metadata for)
> and build the connection
> but when go to library (by clicking Preview button)
> I could not see any file
> not when using search nor in browsing tabs!
>
> I double checked every thing I could thing of, but no change!
>
> I'd appreciate it if any one has any idea what's wrong?
>
> Thanks in advance
>
>
> --
> Farzaneh Ghayour
> M.Sc. Student , Software Engineering
> Department of Computer Engineering
> Sharif University of Technology
> ------------------------------------------------------------------------
>
> _______________________________________________
> greenstone-users mailing list
> greenstone-users@list.scms.waikato.ac.nz
> https://list.scms.waikato.ac.nz/mailman/listinfo/greenstone-users
>