Re: [greenstone-users] GLI Applet - Collection cannot be opened

From Galvin Clancey
DateFri, 1 Sep 2006 10:09:30 -0700
Subject Re: [greenstone-users] GLI Applet - Collection cannot be opened
In-Reply-To (44F7BDEC-3060308-cs-waikato-ac-nz)
Hi Michael,

I tried that file and started up the client-gli.bat file. I logged in exactly as before, but this time it started loading a lot more stuff before it gave the same old error message (The collection at c:. . . . cannot be opened.). I then rebooted the server computer to see if that would help. Now when I use the gli client I get the exact same loading situation as before (without loading all these new things).

Galvin

On 8/31/06, Michael Dewsnip <mdewsnip@cs.waikato.ac.nz> wrote:
Hi Galvin,

Please try downloading
http://www.cs.waikato.ac.nz/~mdewsnip/greenstone/temp-2.70w/gsdlCGI.pm
and overwriting your existing gsdlCGI.pm file in the Greenstone
"cgi-bin" directory on the server.

Does this fix the problem?

Regards,

Michael



Galvin Clancey wrote:

> Michael, the output is:
>
><Error>
>  Perl failed: perl -S buildcol.pl -language "en" -xml  2>&1
>--
>'perl' is not recognized as an internal or external command,
>operable program or batch file.
>
>
>Exit status: 1
>  CGI args were: cmd=get-script-options&script=buildcol.pl&xml=&language=en&un=admin&pw=TpshomFzYCRFk
></Error>
>
>
> Thanks,
>
> Galvin
>
> On 8/30/06, *Michael Dewsnip* <mdewsnip@cs.waikato.ac.nz
> <mailto:mdewsnip@cs.waikato.ac.nz >> wrote:
>
>     Hi Galvin,
>
>     Sorry, you also need to add a valid username and password, ie:
>
>     gliserver.pl?cmd=get-script-options&script=buildcol.pl&xml=&language=en&un= <username>&pw=<password>
>
>     What is the output now?
>
>     Michael
>
>
>
>     Galvin Clancey wrote:
>
>     > Hi Michael,
>     >
>     > The output for that command is as follows:
>     >
>     ><Error>
>     >  No username specified.
>     >  CGI args were:
>     cmd=get-script-options&script= buildcol.pl&xml=&language=en
>     ></Error>
>     >
>     >
>     >
>     > Thanks,
>     >
>     > Galvin
>     >
>     > On 8/29/06, *Michael Dewsnip* < mdewsnip@cs.waikato.ac.nz
>     <mailto:mdewsnip@cs.waikato.ac.nz>
>     > <mailto: mdewsnip@cs.waikato.ac.nz
>     <mailto:mdewsnip@cs.waikato.ac.nz>>> wrote:
>     >
>     >     Hi Galvin,
>     >
>     >     OK, it looks like it's having trouble parsing the plugin and
>     >     classifier
>     >     information from the server. Can you please try accessing
>     >
>     >
>     >
>     http://<server>/gsdl/cgi-bin/gliserver.pl?cmd=get-script-options&script=
>     buildcol.pl&xml=&language=en
>     >
>     >     in your browser and see what the output is.
>     >
>     >     All the best,
>     >
>     >     Michael
>     >
>     >
>