[greenstone-users] Fixing document paths on Greenstone server

From Anupama of Greenstone Team
DateWed Jun 3 18:06:33 2009
Subject [greenstone-users] Fixing document paths on Greenstone server
In-Reply-To (3B1952F4-84A6-4BF1-A330-CA306E0D4777-fe-up-pt)
Hi Cristina,

Since you wrote that your Greenstone installation is at
> /usr/local/Greenstone2/

would you try the following and see if any of them work:


1. First change your Apache configuration file to contain the following
instead of the excerpt you sent us:

ScriptAlias /greenstone "/usr/local/Greenstone2/cgi-bin/library"
ScriptAlias /gsdl/cgi-bin/ "/usr/local/Greenstone2/cgi-bin/"
<Directory "/usr/local/Greenstone2/cgi-bin">
AllowOverride None
Options None
Order allow,deny
Allow from all
</Directory>

Alias /gsdl "/usr/local/Greenstone2"
<Directory "/usr/local/Greenstone2">
Options Indexes MultiViews FollowSymLinks
AllowOverride None
Order allow,deny
Allow from all
</Directory>


2. If that didn't work, then still keep those changes. Now also try
changing:
ScriptAlias /greenstone "/usr/local/Greenstone2/cgi-bin/library"
to
ScriptAlias /greenstone "/usr/local/Greenstone2/cgi-bin/library.cgi"

Does this change do anything useful?


3. If not, then finally, try removing only this line from your apache
configuration file:
ScriptAlias /greenstone "/usr/local/Greenstone2/cgi-bin/library.cgi"

(But keep the very next line, which is:
ScriptAlias /gsdl/cgi-bin/ "/usr/local/Greenstone2/cgi-bin/")


Now check again to see if your images are in the correct place.

4. If not, can you look at your Greenstone2 installation's
"cgi-bin/gsdlsite.cfg"?
And then see steps 8 and 9 of the Greenstone wiki page
http://wiki.greenstone.org/wiki/index.php/Setting_up_an_Apache_Web_Server_for_Greenstone_2_Walkthrough
to make sure you have the correct value for the httpprefix and httpimg
properties, since they are related to what you have for ScriptAlias and
Alias in your Apache configuration file.


Tell us if there's still a problem.
Regards,
Anupama


Cristina Ribeiro wrote:
> Hi
>
> I am having a problem in a linux server installation of Greenstone 2.81.
> Collections are being built with remote clients, and they are previewed
> OK, except for the links to additional objects, such as images or files
> which are apparently not well resolved. The files are located in the
> required directories after building.
>
> Some details on our installation
>
> Greenstone is installed in
> /usr/local/Greenstone2/
> and there is a link in /usr/local named gsdl
> lrwxrwxrwx 1 root staff 23 2009-03-17 16:20 gsdl ->
> /usr/local/Greenstone2/
>
> Our Apache configuration for Greenstone is
>
> ScriptAlias /greenstone "/usr/local/gsdl/cgi-bin/library"
> ScriptAlias /gsdl/cgi-bin/ "/usr/local/gsdl/cgi-bin/"
> <Directory "/usr/local/gsdl/cgi-bin">
> AllowOverride None
> Options None
> Order allow,deny
> Allow from all
> </Directory>
>
> Alias /gsdl/ "/usr/local/gsdl/"
> <Directory "/usr/local/gsdl">
> Options Indexes MultiViews FollowSymLinks
> AllowOverride None
> Order allow,deny
> Allow from all
> </Directory>
>
>
> The links to images in the Greenstone pages look like
>
> http://mymachine.domain/greenstone/collect/...
>
> instead of
>
> http://mymachine.domain/gsdl/collect/...
>
>
> Thanks for any suggestions.
>
> Cristina Ribeiro
> Faculdade de Engenharia- Universidade do Porto
>
>
>
>
>
> ------------------------------------------------------------------------
>
> _______________________________________________
> greenstone-users mailing list
> greenstone-users@list.scms.waikato.ac.nz
> https://list.scms.waikato.ac.nz/mailman/listinfo/greenstone-users