[greenstone-users] Having difficulties to build form the source code in Ubuntu 10.04

From Katherine Don
DateWed Jun 16 11:24:11 2010
Subject [greenstone-users] Having difficulties to build form the source code in Ubuntu 10.04
In-Reply-To (4C0622F9-2020404-gmail-com)
Hi

Apparently you get the STL broken error if you don't have g++.

Regards,
Katherine

Biligsaikhan B. wrote:
> Dear Katherine and the list,
>
> I am having problems to build GSDLv2.82 from the source code on Ubuntu
> Lycid(10.04) with the latest updates e.g, g++, gcc 4.4.3.
>
> Errors are: mg_files.cpp:56: error: invalid conversion from ?const
> char*? to ?char*?
>
> I have tried in CentOS with gcc 3.4.6 20060404 (Red Hat 3.4.6-11).
>
> Error is: "STL Broken - Obtain newer version of GNU C Compiler"
>
> Could you recommend latest the configuration(is it gcc 2.9.5?) that I
> can build without problem?
>
> Your advices are valuable.
>
> Biligsaikhan
> ------------------------------------------------------------------------
>
> _______________________________________________
> greenstone-users mailing list
> greenstone-users@list.scms.waikato.ac.nz
> https://list.scms.waikato.ac.nz/mailman/listinfo/greenstone-users