Re: [greenstone-users] GreenStone 2.52 - linux - plugin problem- collection build fail

From Karen E. Medina
DateTue, 28 Dec 2004 20:34:19 -0600
Subject Re: [greenstone-users] GreenStone 2.52 - linux - plugin problem- collection build fail
In-Reply-To (20041228203346-E5E1523CF6-ws5-3-us4-outblaze-com)
The permissions on the plugins might be a problem?

-karen medina
(Just a guess until the Greenstone folk get back from their holiday.)


On Tue, 28 Dec 2004,
Farid wrote:

> Hi
>
> I've tried to solve the following problem for more than 30 hours but to not much use. Here's the description:
>
> On SuSE 9.2/Redhat 9/ Knoppix 3.6 each fully meeting the requirements (except for a libgdbm-dev package for the src installation) I installed gsdl 2.52 both as binary and from source but each time I run ./gli.sh everything seems to be going ok except for that I can't build any collections not even the demo collection provided by the package itself! i.e. when I try to open the collection/ base a new one on it the following error window pops up right after:
>
> unable to determine the arguments for the GAPlug.pm plugin. Please ensure that the plugin in question provides the -xml flag by running the pluginfo.pl script described in section 2.1 of the greenstoen developer's guide.
>
> The same box shows up but for the following plugins:
>
> METSPlug.pm
> XMLPlug.pm
> RecPlug.pm
>
> Thereafter when I try to build the collection(from scratch/based on some other one etc) I get the following error message:
>
> An error has ocurred which will prevent the collection being previewed.
>
> (does this error have to do anything with the webserver? What should I enter exactly in the first window that shows up at the first run of gli.sh?)
>
> So as told by the dev guid and having run the source setup.bash I cded to the plugins directory and ran this:
>
> pluginfo.pl GAPlug.pm
>
> But here's the result:
>
> ERROR: Could not find pluginGAPlug.pm"
>
> But it's right there!
>
> The error.txt under etc doesn't show anything!
>
> BTW I also tried the Collector from the web-based interface for which I get the following error message when I try to build a collection:
>
> The collection could not be built (import.pl failed).
>
> The build log contains the following information:
>
>
> copying /data/index.html --> /usr/local/gsdl/tmp/tbuild1/MyCol/import/data/index.html
> importing the MyCol collection
> build: ERROR: import.pl failed
>
> Please restart the collector and try again.
>
>
> What's wrong?
> Any pointers would be most appreciated.
>
>
> .
> --
> _____________________________________________________________
> Web-based SMS services available at http://www.operamail.com.
> From your mailbox to local or overseas cell phones.
>
> Powered by Outblaze
>
> _______________________________________________
> greenstone-users mailing list
> greenstone-users@list.scms.waikato.ac.nz
> https://list.scms.waikato.ac.nz/mailman/listinfo/greenstone-users
>

-Karen Medina
--------------------------->>>>>***<<<<<---------------------------
"I often store draft copies of my documents in trifles for security
purposes" -stolen from a webpage

------------------>>>***<<<------------------