[greenstone-users] Librarian Interface dislikes recent JRE version

From Henry Gladney
DateFri, 23 Feb 2007 05:50:55 -0800
Subject [greenstone-users] Librarian Interface dislikes recent JRE version
I am attempting to run the Greenstone Librarian Interface (v2.72) under Linux Ubuntu (version Dapper Dan), with the latest JRE version (v1.5.0_11), and am receiving what seems to be a misleading error message ("The version of the Java Runtime Environment you have installed is too old to run the Greenstone Librarian Interface.")

What should I do?  Or is this a Greenstone bug?

My console file follows.
=====================
gladney@hmglinux:~$ cd ../../gsdl
gladney@hmglinux:/gsdl$ cd gli
gladney@hmglinux:/gsdl/gli$ ./gli.sh

Greenstone Librarian Interface (GLI)
Copyright (C) 2006, New Zealand Digital Library Project, University Of Waikato
GLI comes with ABSOLUTELY NO WARRANTY; for details see LICENSE.txt
This is free software, and you are welcome to redistribute it

Checking GSDL: /gsdl
Your environment has successfully been set up to run Greenstone
Checking Perl: /usr/bin/perl
Checking Java: /usr/bin/java

The version of the Java Runtime Environment you have installed is too
old to run the Greenstone Librarian Interface. Please install a new
version of the JRE (version 1.4 or newer) and rerun this script.
gladney@hmglinux:/gsdl/gli$ sudo su
Password:
root@hmglinux:/gsdl/gli# update-alternatives --config java

There are 3 alternatives which provide `java'.

  Selection    Alternative
-----------------------------------------------
      1        /usr/bin/gij-wrapper-4.1
 +    2        /usr/lib/jvm/java-gcj/jre/bin/java
*     3        /usr/java/jre1.5.0_11/bin/java

Press enter to keep the default[*], or type selection number:
root@hmglinux:/gsdl/gli#
============================

Best wishes, Henry

H.M. Gladney, Ph.D.    http://home.pacbell.net/hgladney/