Re: [greenstone-users] empty page when search gives no result

From Argon7 List User
DateTue, 28 Feb 2006 13:18:06 +0100
Subject Re: [greenstone-users] empty page when search gives no result
In-Reply-To (54397-210-55-139-120-1141083067-squirrel-webmail-scms-waikato-ac-nz)
ooops... you're right, i did customize the macro and i completely forgot
about it...
i've added the missing parenthesis and now everything is working ok...
thanks a lot!
regards,

-- j:o)

mdewsnip@cs.waikato.ac.nz wrote:
> Hi,
>
> Actually you have customised the query:content macro, in extra.dm:
>
>

oops

The requested page could not be found. Please use your browsers 'back' button or the above home button to return to the Greenstone Digital Library. [c=ccfbcata] {
> <!-- start of custom query:content -->
> SearchSubjectsFromDates
>
> _queryform_
> _iconsearchhistorybar_<br>
> _searchhistorylist_
> <small>_freqmsg_ _textpostprocess_</small><br>_resultline_
> <br>
> <!-- end of custom query:content -->
> }
>
> The problem is that there is a )' missing after "_searchhistorylist_" --
> this closes the searchhistorylist If statement. Adding this ')' should fix
> your problem.
>
> Regards,
>
> Michael
>
>
>
>
>>Bonjour (ou bonsoir!)
>>
>>I haven't customize the query:content macro, here is a copy of what is
>>currently in query.dm:
>>
>>

oops

The requested page could not be found. Please use your browsers 'back' button or the above home button to return to the Greenstone Digital Library. {
>><center>
>>
>></center>
>><center>
>>_queryform_
>></center>
>><center>_iconsearchhistorybar_</center><br>
>><center>
>>_searchhistorylist_
>></center>
>><center>_iconqueryresultsbar_</center><br>
>><small>
>>_freqmsg_
>>_textpostprocess_</small><br>
>>_resultline_
>>,<center>_iconblankbar_</center>)<br>
>>}
>>
>>what is the "prabhakarraog&#64;drreddys.com" referred in the last part of content macro? is
>>it possible that i didn't configure a parameter correctly?
>>
>>thanks for your help!
>>
>>-- j:o)
>>
>>John R. McPherson wrote:
>>
>>>On Fri, Feb 24, 2006 at 04:47:00PM +0100, Argon7 List User wrote:
>>>
>>>
>>>>Hi,
>>>>When I do a search and it does not return any document, the specific
>>>>message ("_textnodocs_") is not displayed under the query form...
>>>>Although this message appears correctly as the browser window title,
>>>>strange isn't it?
>>>>What can I do in order to display the message in the search page under
>>>>the query form?
>>>>Please feel free to test it on
>>>>http://cinematheque.cfwb.be/collections.html
>>>
>>>
>>>Bonjour,
>>>
>>>this sentence is created by the server, and stored in the macro
>>>"_resultline_" in the query package - it is referred to in
>>>macros/query.dm.
>>>
>>>If you've customised the query:content macro, check that you haven't
>>>removed the _resultline_ reference.
>>>
>>>John
>>
>>_______________________________________________
>>greenstone-users mailing list
>>greenstone-users@list.scms.waikato.ac.nz
>>https://list.scms.waikato.ac.nz/mailman/listinfo/greenstone-users
>>
>>
>
>
>