Re: install problem on 2.38 for older NT?

From Stefan Boddie
DateTue, 04 Jun 2002 09:17:54 +1200
Subject Re: install problem on 2.38 for older NT?
In-Reply-To (OF2272F634-CC1083B0-ON85256BCD-0051828E-altarum-org)
Hi Steve,

gsdl-2.38 uses a new version of InstallShield which relies on service
pack 6 for NT as you've seen (as well as various other things like the
appropriate version of MSI). Greenstone itself hasn't changed in any way
to require this, it's just the installer.

The old installer we used for gsdl-2.37 was a little outdated and
somewhat flakey on newer Windows platforms however so we had to make the
change.

regards,
Stefan.

steve.brophy@altarum.org wrote:
>
> Hello Greenstone users,
>
> I've hit a problem trying to install the new release, reporting that the
> machine doesn't have the required service pack. The system is Windows NT,
> and the OS on it is: Version 4.0 (Build 1381: Service Pack 4).
>
> Running the gsdl-2.37-win32.exe worked fine. I've uninstalled that one,
> and then ran the new gsdl-2.38-win32.exe.
>
> The error I got was:
> InstallShield
> 1150: Setup has detected an incompatible version of Windows.
> Please click OK and verify that the target system is running
> either Windows 95 (or later version), or Windows NT 4.0
> Service Pack 6 (or later version), before relaunching the installation.
>
> Has something changed in the new release that requires the newer service
> pack, or could the install be fixed to still work with the older machines?
> Or has some other software on this machine confused things? (This
> machine also has Active Perl RC1 Build 611, Cygwin B20, etc).
>
> I'm just checking, this older machine was available for isolated testing,
> but I can locate a different machine or apply the upgrade if needed
>
> thanks,
> Steve
>
> Steve Brophy steve.brophy@altarum.org
> Altarum, Ann Arbor MI