Re: [greenstone-users] Unable to use GLI applet (applet load failed)

From Argon7 List User
DateMon, 18 Apr 2005 00:34:40 +0200
Subject Re: [greenstone-users] Unable to use GLI applet (applet load failed)
In-Reply-To (4262DB55-8020102-cs-waikato-ac-nz)
It seems to do the job as at least the GLI applet loads ok now!
I'll let you know if something else goes wrong using it.

Thanks a lot!

-- J:o)

On Mon, 2005-04-18 at 09:55 +1200, Michael Dewsnip wrote:
> Hi,
>
> Unfortunately there was a bug introduced into the GLI applet v2.53 that
> might be causing your problem. To fix this, edit
> gli/src/org/greenstone/gatherer/GathererApplet.java and find line 116:
>
> "-library", library_cgi,
>
> This should read:
>
> "-library_url", library_cgi,
>
> Save this file, run clean.sh in the gli directory, then do steps 5-10
> again to create the patched applet.
>
> Let me know if this doesn't fix your problem.
>
> Regards,
>
> Michael
>
>
>
> Argon7 List User wrote:
>
> > Hi!
> >
> > I've successfully installed Greenstone and everything is working fine.
> > Then i followed all the steps of the "how-to install GLI as an
> > applet". Unfortunately when i click on "the Librarian Interface"
> > button, the applet failed to load on the page (Firefox message:
> > "Loading Java applet failed" + "Applet gatherer notinited")
> >
> > In the apache error log, i've found:
> > [Thu Apr 14 17:44:56 2005] [error] (13)Permission denied: exec of
> > (...)/gsdl/cgi-bin/org/greenstone/gatherer/GathererApplet.class failed
> > [Thu Apr 14 17:44:56 2005] [error] [client 80.201.131.109] Premature
> > end of script headers:
> > (...)/gsdl/cgi-bin/org/greenstone/gatherer/GathererApplet.class
> > [Thu Apr 14 17:44:56 2005] [error] (13)Permission denied: exec of
> > (...)/gsdl/cgi-bin/org/greenstone/gatherer/GathererApplet.class failed
> > [Thu Apr 14 17:44:56 2005] [error] [client 80.201.131.109] Premature
> > end of script headers:
> > (...)/gsdl/cgi-bin/org/greenstone/gatherer/GathererApplet.class
> >
> > My box is a Linux Debian Woody (kernel 2.4.25), running apache 1.3.26
> > and j2sdk1.4.2_07
> >
> > Any help would be appreciated! Thanks!
> >
> > -- J:o)