Re: [greenstone-users] gli-applet

From Qiu
DateWed, 19 Sep 2007 09:28:04 +1200
Subject Re: [greenstone-users] gli-applet
In-Reply-To (deb74ac70709180839p3762bdcob2ca24560f35606e-mail-gmail-com)
Hi Gary

Could you send me the
GSDLHOME/gli/src/org/greenstone/gatherer/Gatherer.java file? I'm afraid
there is a bug when launching the GLI applet? We have fixed it at GSDL
2.74b.

Regards
Quan

Gary Crook wrote:
>
> I am working on installing Greenstone 2.74 and customizing the user
> interface for my senior capstone project. I have Greenstone running on
> a server that is running RedHat Enterprise Linux 4. Everything seems
> to work except the gli-applet. The applet loads, I am able to launch
> the Greenstone Librarian Interface and enter my user name and password
> into the dialog box. That seems to authenticate okay. None of the
> buttons on the GLI interface are active except the help button and the
> Gatherer, I am able to navigate the entire help system and the
> Workspace. The three window controls are also active. The File menu
> and Edit menu are inactive. I have installed the gli-client on another
> computer and that can access Greenstone running on the server and
> create new collections. I am in the all-collections-editor and
> administrator groups. The only permissions that I have changed is to
> set collect to 777 and tmp to 777, but if the GLI client works then I
> assume permissions are not the problem.
>
> I have installed, uninstalled, and re-installed Greenstone many times
> now on both Linux and W2k. It takes me about 15-20 minutes start to
> finish, but I can't get passed this point.
> Why are the controls on the gli applet inactive? Have I overlooked
> something in the documentation?
>
>
> Thank you for your help,
>
> Gary Crook
> ------------------------------------------------------------------------
>
> _______________________________________________
> greenstone-users mailing list
> greenstone-users@list.scms.waikato.ac.nz
> https://list.scms.waikato.ac.nz/mailman/listinfo/greenstone-users
>