[greenstone-users] problems with building demo under MacOSX

From Jeremy Mears
DateMon, 15 Dec 2003 23:05:59 +1100
Subject [greenstone-users] problems with building demo under MacOSX
Hello,

I've just started learning about Greenstone (MacOSX 2.40a, seemed to
install fine) for a job that landed on my desk. Major newbie status
here.

I downloaded all the docs, read the users guide and was following the
instructions for building in the developers guide to build the demo
library to get a feel for the program. I've been using GLI, but also
tried the web interface as well. I get the same sort of error when i
go to build. I'm sure i'm following the instructions properly, but who
knows ;)

Basically i create a new collection, then include the source data and
then try to build. I get the following error about plugins:
"GLI has been unable to determine the arguments for the ArcPlug plugin.
Please ensure that the plugin in question provides the -xml flag by
running the pluginfo.pl script described in section 2.1 of the
Greenstone Developers Guide"

That error dialog comes up for each plugin.

I also get the following error log:

Command: /Applications/Greenstone/bin/script/import.pl -importdir
/Applications/Greenstone/collect/clonedem/gimport/ clonedem -archivedir
/Volumes/Beryl II/Jobs/NHMRC
import.pl> couldn't find diagnostic data in
/System/Library/Perl/5.8.1/pods/perldiag.pod
/Applications/Greenstone/collect/clonedem/perllib
/Applications/Greenstone/perllib/classify
/Applications/Greenstone/perllib/plugins
/Applications/Greenstone/perllib
/System/Library/Perl/5.8.1/darwin-thread-multi-2level
/System/Library/Perl/5.8.1
/Library/Perl/5.8.1/darwin-thread-multi-2level /Library/Perl/5.8.1
/Library/Perl /Network/Library/Perl/5.8.1/darwin-thread-multi-2level
/Network/Library/Perl/5.8.1 /Network/Library/Perl .
/Applications/Greenstone/bin/script/import.pl at
/System/Library/Perl/5.8.1/diagnostics.pm line 252, <POD_DIAG> line
617.
import.pl> Compilation failed in require at
/Applications/Greenstone/perllib/acronym.pm line 28, <POD_DIAG> line
617.
import.pl> BEGIN failed--compilation aborted at
/Applications/Greenstone/perllib/acronym.pm line 28, <POD_DIAG> line
617.
import.pl> Compilation failed in require at
/Applications/Greenstone/perllib/plugins/BasPlug.pm line 39, <POD_DIAG>
line 617.
import.pl> BEGIN failed--compilation aborted at
/Applications/Greenstone/perllib/plugins/BasPlug.pm line 39, <POD_DIAG>
line 617.
import.pl> Compilation failed in require at
/Applications/Greenstone/perllib/plugins/ZIPPlug.pm line 49, <POD_DIAG>
line 617.
import.pl> BEGIN failed--compilation aborted at
/Applications/Greenstone/perllib/plugins/ZIPPlug.pm line 49, <POD_DIAG>
line 617.
import.pl> Compilation failed in require at
/Applications/Greenstone/perllib/plugin.pm line 55, <POD_DIAG> line
617.
import.pl> Command failed.

Btw, i'm a Graphic Designer with a stack of inDesign docs to make into
a Library. Anyone out there done something similar? I working my way
thru the docs and it's sort of making sense but this plugin thing has
gotten me stumped. I'd appreciate any help the fine folks out there
can give me :)

tia

Jeremy

--
Jeremy Mears Design
<http://www.jeremymearsdesign.com/>