[greenstone-users] Explode Metadata Database window does not open(for bibliographic data)

From nadia k
DateTue Apr 7 08:09:03 2009
Subject [greenstone-users] Explode Metadata Database window does not open(for bibliographic data)
In-Reply-To (6b234dbb0904061014m224c7466j744354ec46d13904-mail-gmail-com)
Dear Nisa,

This previous email from John solved the same problem for me...

[]'s
nadia.
+++++++++++++++++++++++++++
Dear Renate,

The problem with the explode option for CDS/ISIS in version 2.81 was
discussed previously on the list, and a fix was given on 4 February:

********
1. Please go into your Greenstone installation folder's
gli/src/org/greenstone/gatherer/util
And make a copy of the file "RemoveContentBeforeRootElementXMLReader.java"
Rename this copy as RemoveContentBeforeRootElementXMLReader.java_orig

2. Download the updated file from:
http://svn.greenstone.org/gli/trunk/src/org/greenstone/gatherer/util/RemoveContentBeforeRootElementXMLReader.java

3. Put the downloaded file in gli/src/org/greenstone/gatherer/util to
replace the original.

4. Open a Windows DOS console or Linux xterm, go into your Greenstone
installation folder. Then change into your gli directory:
> cd gli

5. Now you're inside the GLI folder, compile up GLI by typing the
following in a Windows DOS prompt:
> makegli.bat
Or by typing the following in a Linux x-term:
> ./makegli.sh

6. Try to run GLI and explode that CDS/ISIS database again.
********
Please do try this fix and report if there are still problems. I'm
asking the Waikato team to confirm that this fix has been
incorporated in the nightly release snapshots, and also to inform
whether the problem is restricted to exploding with CDS/ISIS or might
occur when exploding other database formats as well.

Concerning the problem of errors when rebuilding an "as is" CDS/ISIS
collection (bibliographic data only without exploding), you first
said that it did not work when the comma default for the
subfield_separator parameter is set in the ISISPlugin but now you are
also implying that there is a problem with the default of <br> for
the entry_separator. These parameters are only used to format the
data in the built collection for screen output, to separate subfields
and occurrences of repeatable fields respectively. When I try to
build the CDS/ISIS example collection with 2.81, I get the error "The
bad argument occurred in plugin ISISPlugin." which goes away when I
unselect the subfield_separator parameter (not when I change its
value). This seems to be a bug, asking Waikato colleagues to check.
The collection builds with the default entry_separator, could you
please explain if you meant to say that there is also a problem with
this parameter?

Best regards, John

Date: Mon, 6 Apr 2009 19:14:22 +0200
From: k.n.fachry@gmail.com
To: greenstone-users@list.scms.waikato.ac.nz
Subject: [greenstone-users] Explode Metadata Database window does not open(for bibliographic data)

Dear all,

I am trying to make a bibliographic collection using greenstone 2.81 but I have a problem when trying to explode the database.

I simply follow this tutorial:

http://wiki.greenstone.org/wiki/gsdoc/tutorial/en/bibliography_collection.htm

Specifically in step number 16, I right clicked on the marc file and clicked on the Explode Metadata Database. A window should open with options for the exploding process. However, this window did not open. Does nyone know how to solve this problem?


Thanks in advance.
Regards,
Nisa

_________________________________________________________________
Fa□a j□ uma busa e ganhe um wink do Messenger. Est□ esperando o que? □ gr□tis!
http://www.ibud.com.br/
-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://list.scms.waikato.ac.nz/mailman/private/greenstone-users/attachments/20090406/abd7c147/attachment.html