Re: [greenstone-users] GLI not functioning with Ubuntu

From Bret Wiebe
DateThu, 29 Mar 2007 09:40:03 -0700
Subject Re: [greenstone-users] GLI not functioning with Ubuntu
In-Reply-To (460B2F2D-8090002-cs-waikato-ac-nz)
Someone replied off list with the solution. It was indeed a problem with
the perl XML parser module. I used the suggested solution found at:
http://greenstone.sourceforge.net/wiki/index.php/Building_Greenstone_collections#How_do_I_fix_XML::Parser_errors_during_import.
It seems to work fine now. Thank you Graeme and Michael.

Bret Wiebe
Prince Rupert Library


Michael Dewsnip wrote:
> Hi Bret,
>
> This is likely to be a problem with the Perl XML::Parser module. Try:
>
> cd /usr/local/gsdl
> source setup.bash
> pluginfo.pl -xml -listall
>
> Do you get a lot of XML output, or errors?
>
> Regards,
>
> Michael
> DL Consulting Ltd.
>
>
>
> Bret Wiebe wrote:
>
>> Hi,
>>
>> I've installed Greenstone v2.72 on a box running Ubuntu 5.10, kernel
>> 2.6.12-10. It works great for accessing the demo collection over the
>> web but the GLI is not working. There are basically two errors in
>> functionality: (1) when I try to open the demo collection the result
>> is a message "The collection at: /usr/local/gsdl/collect/demo/demo.col
>> cannot be opened." (2) when I then try to close GLI the cursor changes
>> to 'please wait' mode and then nothing happens, I have to Ctrl-C in
>> the terminal window to end the program.
>>
>> The computer is presently running Apache 2.0.54-5, perl 5.8.7 and jre
>> 1.6.0 I have also tried using jre 1.4.2_13 but the same behaviour
>> occurred. I think that the jre is working okay because the "Greenstone
>> Editor for Metadata Sets" seems to work fine - I can open, edit and
>> save files and then exit the app with no errors.
>>
>> The text from the console while running GLI is included below. Any
>> suggestions on what else to check or how to rectify this would be
>> greatly appreciated.
>>