[greenstone-users] Compiling 2.40 on MacOSX?

From Carl Jones
DateThu, 3 Jul 2003 02:06:13 -0400
Subject [greenstone-users] Compiling 2.40 on MacOSX?
Hi,

Has anyone successfully compiled the latest release on MacOSX 10.2.*?

I'm getting the following error:

../../packages/mg/lib/getopt.h:105: declaration of C function `int
getopt()'
conflicts with
/usr/include/unistd.h:142: previous declaration `int getopt(int, char*
const*,
const char*)' here
make[1]: *** [phindaction.o] Error 1
make: *** [all] Error 1


Thanks.

Carl