Re: [greenstone-devel] PageImg collection display issue

From Katherine Don
DateFri, 19 Nov 2004 10:18:22 +1300
Subject Re: [greenstone-devel] PageImg collection display issue
In-Reply-To (419CD7A1-302-bellsouth-net)
Hi Beth

I have tried your format statement (from the collect.cfg of auburnbo)
and it worked fine for me (the commented out one using cgiargsize).
The only problem was that the choice of large or small image was not
carried over between pages - this is because size is not a proper
argument in my library and doesn't get saved.
If I change the format statement to use the p arg, then it still works
fine, and you can navigate between pages even at large size.
I chose p for the argument because it isn't otherwise used by the
document display code.

I tried to look at your library but you had switched back to the old
version of the format statement. If you can put the format back to the
one thats not working, I can have a look at it for you.

Regards,
Katherine Don

PS Have you changed your Greenstone at all?


Beth Nicol wrote:
> I am building a collection using the PageImgPlug that contains page
> images (jpegs) and the associated OCR's text. It builds beautifully as
> far as I can tell. But, then I get into formatting issues for the pages:
>
> Environment: GSDL 2.51, RedHat Linux Enterprise, binary install (Apache
> 1.3 server)
>
> When I use the following format string, I get a nice display sized
> image sitting alongside the full-OCR's text for the page.
>
> format DocumentText "<center><table width=537><tr><td
> valign="top">[srclink]View fullsize imag
> e[/srclink]<br />{If}{[screenicon],[screenicon],'where is that
> picture?'}</td><td valign="top">[Text]
> </td></tr></table></center>"
>
> However, when I use this format string and select the "small" view,
> which is the one which I expect to replicated the format I have above, I
> get a nice display sized image alongside only the OCR'd text for
> perhaps the first line or first paragraph: (this format comes primarily
> from the example in the plugin file itself)
>
> format DocumentText "<center><table
> width=537><tr><td><a href=_ht
> tpdocument_&d=419D119E-90209-cs-waikato-ac-nz&p=small>Switch to small version.</a><br /><a
> href=/gsdlmod?e=d-00000-00---off-0gsarch--00-0----0-10-0---0---0direct-10---4-----dfr--0-1l--11-en-50---20-help-PaingThu+Chit--00-0-1-00-0--4----0-0-11-10-0utfZz-8-00&a=d&d=419D119E-90209-cs-waikato-ac-nz&p=small title=View Image with
> Text>[srcicon]</a></td></tr></table></center>"
>
> I've looked at the source of the presented page, and sure enough - the
> <pre> text starts - the </pre> tag is never closed, and the data is
> nowhere to be found.
>
> I've looked at the format line 'til I'm cross-eyed and I can't see
> anything there, so my guess is that there might be a bug in the code
> when the presentation (p=small) is invoked.
>
> Help. Ideas? The collection is at
> http://automation.lib.auburn.edu/gsdl/cgi-bin/library - it's the Auburn
> Board of Trustees minutes - but I'm working with it, so no guarantees
> that it will be set up to see the error at any given time!
>