Re: [greenstone-devel] Solaris installation problem

From Alain Veylit
DateMon, 31 Oct 2005 19:05:44 -0800
Subject Re: [greenstone-devel] Solaris installation problem
In-Reply-To (4366AF6A-1010504-ucr-edu)
Hi all,
I am still trying to build the simple image collection - everything
works except that the thumbnails are not created .
If I run the import.pl script in debug mode I get the following error:
Can't locate object method "getoutputdir" via package "docprint" at
/res/apps/gsdl/gsdl/perllib/plugins/RecPlug.pm line 170.

The buildcol script in debug mode generates messages like:
WARNING: No plugin could recognise

Notes: the collection does not build with the debug switch on, but it
does in regular mode - probably intentional when there is an error?

Also, all import and buildcol scripts on my solaris machine generate an
error related to the language setting:
Use of uninitialized value in string eq at
/res/apps/gsdl/gsdl/perllib/gsprintf.pm line 177, i.e.:.
if ($defaultresourcebundle{"{Language.code}"} eq "en") ...

Thanks for your advice on this,
Alain

Alain Veylit wrote:

> Hi,
> I am going through the samples. I am getting the error messages below
> - I also have a problem with the simple image sample, i.e. the
> thumbnails are not produced.
> ImageMagick seems to be installed correctly on our machine (Sparc
> Solaris9). The tmp directory in the root gsdl directory is
> universally writable.
> What am I missing?
> Alain
>
>
> OAIPlug: passing metadata on to srcdocs/01dlb19.jpg
> ImagePlug processing srcdocs/01dlb19.jpg
> ImagePlug: couldn't find "/res/apps/gsdl/gsdl/tmp/F356.jpg"
> OAIPlug: passing metadata on to srcdocs/01dlb20.jpg
> ImagePlug processing srcdocs/01dlb20.jpg
> ImagePlug: couldn't find "/res/apps/gsdl/gsdl/tmp/F946.jpg"
>
>