[greenstone-users] Missing documents!

From Daniel Mulholland
DateMon, 4 Jul 2005 19:27:53 +1200
Subject [greenstone-users] Missing documents!

Hi,

 

For a few days, I’ve been adding material. As I’ve increased the number of documents in my collection, some now fail to show up in a VList under the Title classifier in my own metadata set.

 

To be precise, the number is capped at 30. I can’t see why this would be, as under other classifiers the correct number of documents (61, in a hierarchical classifier called ‘MaterialType’) show up (incidentally I have not limited the maximum number of documents in the Build section).

 

When I build my collection, it processes all 61 documents without any errors. Additionally the ones left out don’t appear to be just the ones at the start or just the ones at the end. The build log doesn’t seem to shed any light on the matter for me.

 

I presumed I was having some kind of indexing problem, so I did a title search for one of the missing documents and it appeared. So I’ve scratched that theory. Then I thought, maybe my classifier is problematic (it is fairly simple, although it does handle PDF and HTML files differently), so I replaced it with the simple demo classifier, just changing the metadata name so it refers to my metadataset. Again, no luck. Then I thought, maybe my metadata set is screwy, so I changed the classifier so it referred to ex.Title. Again – the same number of documents. Finally, I thought maybe it’s related to the number of results per page – but again, I drew a blank.

 

Any suggestions or places to look?

 

Regards,

 

Daniel