Re: [greenstone-devel] utf collection folder names strange behaviour

From Michael Dewsnip
DateFri, 17 Jun 2005 15:37:30 +1200
Subject Re: [greenstone-devel] utf collection folder names strange behaviour
In-Reply-To (1118911523-42b13c2402c09-my-ceid-upatras-gr)
Hi,

Although there is no theoretical reason why Greenstone shouldn't work
with Unicode filenames, in practice this hasn't had much testing and I
imagine there will be a few bugs (I've just fixed one in util.pm).

The Perl that is used to run the Greenstone scripts must also be told to
use Unicode -- with Perl 5.6 and 5.8.0 this means adding the "-C" flag, eg:

perl -S -C import.pl mycolname

I'm not sure about newer versions of Perl.

I've been unable to reproduce your problem, however. Could you please
provide a very small collection that shows this problem when built?
(Which version of Greenstone are you using?)

Regards,

Michael

>I get a strange behaviour when i use greek names for the subfolders of my
>collection. The collection uses PagedImagePlug. For examle, i have
>mycolname/□□□□□□□□□□1 etc ... When the collection is built it prints:
>"import.pl> util::hard_link: unable to create hard link. Attempting to copy
>file: C:Greenstonecollectmycolnameimport���1�������scan15453.jpg ->
>C:GreenstonecollectmycolnamearchivesHASH018f.dirscan15453.jpg" and
>
>"WARNING: No plugin could recognise myfile.item". The collection works fine
>then (successful built) but why does it happen when i use the greek characters
>(with english chars it doesn't attempt to copy).
>
>Thanks for any info.
>
>