Re: [greenstone-users] Re: applet gatherer notinited error while running GLI applet

From Michael Dewsnip
DateFri, 16 Jun 2006 14:44:25 +1200
Subject Re: [greenstone-users] Re: applet gatherer notinited error while running GLI applet
In-Reply-To (20060531094808-19271-qmail-web8910-mail-in-yahoo-com)
Hi,

> The error "applet gatherer notinited" was not found when I disabled
> IIS and used Apache as webserver. After browsing the homepage of
> digital library and thereafter running GLI as an applet, GLI screen
> was successfully displayed on the screen. Now, when I click File>Open
> GLI prompts for a password. After entering default user: Admin psswd:
> admin following message was displayed.
>
> An error has occurred on the Remote GLI while performing this action
> http://servername/gsdl/cgi-bin/gliserver
>
> Because of this no collection could be opened remotely.

This was a bug in Greenstone 2.70 that affected the applet version only.
Please upgrade to 2.70w and try again.

> Was the earlier applet error, which I received when, run GSDL on IIS
> is IIS specific, because with same instillation, Apache successfully
> ran GLI remotely?

I've never tested the GLI applet with IIS. I've added it my "to do"
list, but IIS support is fairly low priority (our University has a
policy against installing IIS because of its security problems -- the
only way I could get it installed was to put it on a computer not
connected to any networks).

Regards,

Michael

> */Sharad Jadhav <sharad7703&#64;yahoo.co.in>/* wrote:
>
> hi,
>
> After following instructions for running GLI as applet from
> http://www.cs.waikato.ac.nz/~mdewsnip/greenstone/west-yorkshire/remote-greenstone.html
> <http://www.cs.waikato.ac.nz/%7Emdewsnip/greenstone/west-yorkshire/remote-greenstone.html> I
> got following error when I tried to run GLI from the browser.
>
> error (displayed in status bar of IE 6.0) : applet gatherer notinited
> loading java applet failed
>
> further, When I tried to run check-installation cmd for Java, the
> contents of gliserver.pl file was displayed as plain text. Not
> Java Found/ not found message was displayed.
>
> http://localhost/digital/gliserver.pl?cmd=check-installation
>
> I have appended E:gsdlnewbinwindowsperlbin to
> gliserver.pl file, is this okay.
>
> More info Windows 2000 with IIS gsdl ver 2.70
>
> What could be the problem or had I missed something?
>
> -Sharad
> ------------------------------------------------------------------------
> Yahoo! India Answers: Share what you know. Learn something new
> Click here
> <http://us.rd.yahoo.com/mail/in/mailanswersshare/*http://in.answers.yahoo.com/>
> Send free SMS to your Friends on Mobile from your Yahoo! Messenger
> Download now
> <http://us.rd.yahoo.com/mail/in/freesms/*http://messenger.yahoo.com/download.php>_______________________________________________
> greenstone-users mailing list
> greenstone-users@list.scms.waikato.ac.nz
> https://list.scms.waikato.ac.nz/mailman/listinfo/greenstone-users
>
>
> ------------------------------------------------------------------------
> Yahoo! India Answers: Share what you know. Learn something new Click
> here
> <http://us.rd.yahoo.com/mail/in/mailanswersshare/*http://in.answers.yahoo.com/>
> Send free SMS to your Friends on Mobile from your Yahoo! Messenger
> Download now
> <http://us.rd.yahoo.com/mail/in/freesms/*http://messenger.yahoo.com/download.php>
>
>
>------------------------------------------------------------------------
>
>_______________________________________________
>greenstone-users mailing list
>greenstone-users@list.scms.waikato.ac.nz
>https://list.scms.waikato.ac.nz/mailman/listinfo/greenstone-users
>
>