RE: [greenstone-users] Problem with Ubuntu Linux and GTK

From H.M. Gladney
DateTue, 13 Mar 2007 08:28:35 -0700
Subject RE: [greenstone-users] Problem with Ubuntu Linux and GTK
In-Reply-To (45F4D4BD-7080105-cs-waikato-ac-nz)
Thank you for your replies.
 
I did have Sun Java version 1.4.2 installed.  Apparently my attempt to uninstall GNU Java was not successful.  Maybe that was selected instead of the Sun version.  To confirm this, I just now executed the "java -version" shell command.   The response (abbreviated) was:
 
    java version "1.4.2"
    gij
 
Now I need to figure out how to make Sun Java the default.
 
Cheerio, Henry

From: Michael Dewsnip [mailto:mdewsnip@cs.waikato.ac.nz]
Sent: Sunday, March 11, 2007 9:19 PM
To: H.M. Gladney
Cc: greenstone-users@list.scms.waikato.ac.nz
Subject: Re: [greenstone-users] Problem with Ubuntu Linux and GTK

Hi,

It looks like you're using the GNU Java Runtime, which isn't yet completely compatible with the Sun Java Runtime and won't run the Greenstone Librarian Interface. Installing the Sun Java Runtime (version 1.4.2 or newer) should fix your problem.

Regards,

Michael

-----Original Message-----

From: sw64@cs.waikato.ac.nz [mailto:sw64@cs.waikato.ac.nz]

Sent: Sunday, March 11, 2007 8:48 PM

To: H.M. Gladney

Cc: greenstone-users@list.scms.waikato.ac.nz

Subject: Re: [greenstone-users] Problem with Ubuntu Linux and GTK

Hello Henry,

It seemed your system doesn't use the standard java. You can get one from the sun's web site http://java.sun.com/javase/downloads/index_jdk5.jsp.

It'll also solve your previous problem of not being able to install Greenstone3.

Regards

Shaoqun


From: graeme [mailto:foster.graeme@gmail.com]
Sent: Sunday, March 11, 2007 8:37 PM
To: H.M. Gladney
Subject: Re: [greenstone-users] Problem with Ubuntu Linux and GTK

I don't know if this is your problem but as far as I an aware Greenstone requires Java from Sun, and I am not certain if the version that comes with Ubuntu is Sun's or another's.

graeme.