Re: [greenstone-users] Lucene

From Michael Dewsnip
DateThu, 05 Oct 2006 13:41:45 +1300
Subject Re: [greenstone-users] Lucene
In-Reply-To (EE1AF18EB3686C459A38EBECE3BD5198A60677-ex1-its-waikato-ac-nz)
Hi James,

The history.db error is a red herring actually, and isn't related to
Lucene searching. If you make this file writeable by everyone then the
error will go away.

Back to Lucene, you should check that the
/opt/greenstone/bin/script/lucene_query.pl file has execute permissions
for everyone: chmod a+x lucene_query.pl.

Regards,

Michael

James Brunskill wrote:

>Hi Michael,
>
>Good thinking with permissions on error.txt. I recreated that file so
>that I could filter out all the old junk (of course the permissions were
>wrong)
>
>**** in lucene search
>**** query string = TX:(+law)
>**** escaped query string = TX:(+law)
>***** index name = /opt/greenstone/collect/lucenete/index/didx
>Lucene command: "/opt/greenstone/bin/script/lucene_query.pl"
>"/opt/greenstone/collect/lucenete/index/didx" "TX:(+law)"
>**** xml_text =
>database open failed on: /opt/greenstone/etc/history.db
>
>history.db seems to be 0 bytes. The lucene_query.pl command works fine
>from the commandline, so I guess it must be something to do with the
>history.db
>
>Regards,
>
>James Brunskill
>Library Systems Consultant
>The University of Waikato
>Ph: +64 7 838 4323
>
>
>
>>-----Original Message-----
>>From: Michael Dewsnip [mailto:mdewsnip@cs.waikato.ac.nz]
>>Sent: Thursday, 5 October 2006 1:02 p.m.
>>To: James Brunskill
>>Cc: greenstone-users@list.scms.waikato.ac.nz
>>Subject: Re: [greenstone-users] Lucene
>>
>>Hi James,
>>
>>You'll need to make sure the error.txt file is writeable by all, ie.
>>
>> chmod a+w error.txt
>>
>>You should also look in your webserver error log.
>>
>>Greenstone's support for Lucene has improved dramatically recently;
>>these changes will be in Greenstone v2.71 (any day now).
>>
>>Regards,
>>
>>Michael
>>
>>
>>
>>James Brunskill wrote:
>>
>>
>>
>>>Hi,
>>>
>>>I have been trying to get the lucene indexer to work on a linux
>>>
>>>
>machine,
>
>
>>>gs version 2.70.
>>>
>>>The collection appears to build ok, and classifer navigation works
>>>
>>>
>fine,
>
>
>>>but all searches return no documents.
>>>
>>>Can any one point me in the right direction to track down what is
>>>
>>>
>going
>
>
>>>on? Nothing seems to be written to errors.txt
>>>I'm not sure what other logs are available...
>>>
>>>Regards,
>>>
>>>James Brunskill
>>>Library Systems Consultant
>>>The University of Waikato
>>>Ph: +64 7 838 4323
>>>
>>>
>>>
>>>
>>>
>>>
>>-----------------------------------------------------------------------
>>
>>
>-
>
>
>>>_______________________________________________
>>>greenstone-users mailing list
>>>greenstone-users@list.scms.waikato.ac.nz
>>>https://list.scms.waikato.ac.nz/mailman/listinfo/greenstone-users
>>>
>>>
>>>
>>>
>
>
>
>
>