FW: [greenstone-users] Librarian interface startup failure

From H.M. Gladney
DateSat, 12 May 2007 05:53:38 -0700
Subject FW: [greenstone-users] Librarian interface startup failure
Graeme, thank you for paying attention.  It is Sun Java.  Yes, this is part of the path.
 
Yesterday the same command worked (several times).  Today the error popped up.
 
Specifically, the following console log shows the current Java situation:
 
gladney@HMGlinux:~$ sudo update-alternatives --config java
Password:

There are 2 alternatives which provide `java'.

  Selection    Alternative
-----------------------------------------------
          1    /usr/bin/gij-wrapper-4.1
*+        2    /usr/lib/j2se/1.4/bin/java

Press enter to keep the default[*], or type selection number:


From: graeme [mailto:foster.graeme@gmail.com]
Sent: Friday, May 11, 2007 4:32 PM
To: H.M. Gladney
Cc: greenstone-users@list.scms.waikato.ac.nz
Subject: Re: [greenstone-users] Librarian interface startup failure

Is you path to java set up correctly?

You said java version .../j2se/1.4/... is that part of your path to the java files? I ask because the Java version used is /usr/bin/java. If this is not the correct version then you will want to adjust the path what do you get when you type java --version? Is it the sun or gnu java that is being used?

graeme.

On 5/11/07, H.M. Gladney <hgladney@gmail.com> wrote:
See the attached console file.  Environment: Kubuntu 7.04; java version .../j2se/1.4/...
 
This installation of GSDL Librarian interface has run successfully.
 
What do I do now?
 
Cheerio, Henry