RE: Web library installed on a WIn2000 server with IIS5.0

From Marie-Jose Quintard
DateThu, 20 Feb 2003 11:21:03 +1100
Subject RE: Web library installed on a WIn2000 server with IIS5.0

Sorry for that, I forgot to post the solution to my problem to the list.

-----Original Message-----
From: Marie-Jose Quintard
Sent: Wednesday, February 19, 2003 15:04 PM
To: 'Stefan Boddie'
Cc: 'grahamg@cyberone.com.au'
Subject: RE: Web library installed on a WIn2000 server with IIS5.0


OK, it works just fine now and here is the working setup for IIS5.0/Win2000 server:
open IIS and:
- create a virtual directory for gsdl(pointed to the gsdl folder)
- create a virtual directory for cgi-bin(pointed to cgi-bin under GSDL)
- leave the gwcgi line commented out(default) in gsdlsite.cfg.
(to create a virtual library in IIS: Action/new/virtual library)

I think that when I did my first test, the virtual directory for cgi-bin was not
correct(not under gsdl) that the reason why I had to validate the gwcgi in the gsdlsite.cfg file
with /cgi-bin/library to have the first page displayed.

Thanks a lot for the help,
Cheers
MarieJo
-----Original Message-----
From: Mantione, Joe [mailto:mantione@buffalo.edu]
Sent: Thursday, February 20, 2003 6:35 AM
To: 'Stefan Boddie'; Graham S. Green; 'Marie-Jose Quintard';
greenstone@tripath.colosys.net
Subject: RE: Web library installed on a WIn2000 server with IIS5.0


I can add something to this thread.

Go into IIS,
        1) create a web site for Greenstone
        2) point the default directory to where you have greenstone
installed (in my case d:programsgsdl. I reinstalled GS into d:programs
because the space in "d:program files" was making IMagePlus call to
imagemagick's convert program nuts.)
        3) go to the cgi-bin directory and set the Execute permissions to
'Scripts and Executables'. The default is 'Scripts Only'.
        4) comment out the gsdlhome and httprepfix variables in the
gsdlsite.cfg file

#gsdlhome    "D:Programsgsdl"
#httpprefix  /gsdl
httpimg     images
gwcgi       cgi-binlibrary
maxrequests 10000

        5) stop and start the greenstone web site in IIS.

        After that I was fine except I couldn't see the greenstone menu
images because the packages kept looking for them in
d:programsgsdlgsdlimages instead of d:programsgsdlimages. Instead of
fighting with the thing I copied the images tree to gsdlimages. It worked.
I know when I beat.

Good Luck, Hope that helps a little.

Joe Mantione
University at Buffalo

Here is what we have so far as we are still trying to get Greenstone to
display images.
http://gsdl.pn.buffalo.edu/cgi-bin/library.exe


-----Original Message-----
From: Stefan Boddie [mailto:sjboddie@cs.waikato.ac.nz]
Sent: Tuesday, February 18, 2003 6:56 PM
To: Graham S. Green; 'Marie-Jose Quintard';
greenstone@tripath.colosys.net
Subject: Re: Web library installed on a WIn2000 server with IIS5.0


As John McP suggested previously, you probably need to edit your
gsdlcgi-bingsdlsite.cfg file.

When you say that after clicking any link you get a "page not found" error,
what does the URL in the location bar of your browser look like after
clicking the link? It should look like
http://<my server name>.<my domain name>/gsdl/cgi-bin/library?...... If it
doesn't (for example, if the "gsdl", "cgi-bin", or "library" parts are
missing) then there's a problem in your configuration, probably in
gsdlsite.cfg.

You might also try using http://.../gsdl/cgi-bin/library.exe as I have a
vague recollection of the ".exe" being required by IIS. I don't have IIS
installed right now but have used it in the past without any problems.

Stefan.

----- Original Message -----
From: "Graham S. Green" <grahamg@cyberone.com.au>
To: "'Marie-Jose Quintard'" <MarieJoQ@spc.int>;
<greenstone@tripath.colosys.net>
Sent: Wednesday, February 19, 2003 12:08 PM
Subject: RE: Web library installed on a WIn2000 server with IIS5.0


I am trying to but am not having much luck with it (mainly IIS at this
stage)....


Graham

-----Original Message-----
From: owner-tripath-users@colosys.net
[mailto:owner-tripath-users@colosys.net] On Behalf Of Marie-Jose
Quintard
Sent: Wednesday, 19 February 2003 06:03
To: greenstone@tripath.colosys.net
Subject: RE: Web library installed on a WIn2000 server with IIS5.0


Anybody on this mailing list using the Web library on a IIS5.0/Win2000
server?



-----Original Message-----
From: Marie-Jose Quintard [mailto:MarieJoQ@spc.int]
Sent: Monday, February 17, 2003 9:21 AM
To: greenstone@tripath.colosys.net
Subject: Web library installed on a WIn2000 server with IIS5.0



Good morning,

I have installed the Greenstone Web library on a Win2000 server SP3
with IIS 5.0.
I have defined cgi-bin and gsdl as virtual folder under IIS.

I can access the main page of Greenstone with the URL:
http: // <my server name>.<my domain name>/gsdl/cgi-bin/library

but after, if I click on any of the link on this main page, I got the
following error
message:
"the page is not found".

Any idea to solve this problem is welcome.
Thanks

Marie-Josâ–ˇ Quintard (ICT)
Secretariat of the Pacific Community
SPC Private Mail Bag
Suva - Fiji Islands
Tel: (679) 370 733
Fax: (679) 370 021
Email: MarieJoQ@spc.int
http://www.spc.int