[greenstone-users] Thumbnails working fine from command line, failing with GLI

From Matt Bailey
DateWed Oct 27 02:32:12 2010
Subject [greenstone-users] Thumbnails working fine from command line, failing with GLI
I've been setting up a greenstone instance for a professor here at DU
on RHEL 5.5 32bit, greenstone 2.83

GLI fails as such:
http://i.imgur.com/rwV0y.png


The same exact command runs fine from the command line: (greenstone's
apache is running as the same user)
$ full-import.pl -collectdir "/home/xiaohu/Greenstone/collect" -gli
-language "en" xiao-photo
<Import>
Removing current contents of the archives directory...
<File n=''>
Global file scan checking directory:
/home/xiaohu/Greenstone/collect/xiao-photo/import
<File n='Boston City Flow.jpg'>
<File n='metadata.xml'>
<File n=''>
<File n='Boston City Flow.jpg'>
<File n='metadata.xml'>

<Processing n='metadata.xml' p='MetadataXMLPlugin'>
MetadataXMLPlugin: processing metadata.xml
<File n='Boston City Flow.jpg'>
<Processing n='Boston City Flow.jpg' p='ImagePlugin'>
ImagePlugin processing Boston City Flow.jpg
Converting image Boston City Flow.jpg to: THUMB gif ...
...done
Converting image Boston City Flow.jpg to: SCREEN jpeg ...
...done

*********************************************
Import complete
*********************************************
<ImportComplete considered='1' processed='1' blocked='0' ignored='0' failed='0'>
* 1 document was considered for processing
* 1 was processed and included in the collection

I think apache is not finding the imagemagick perl modules, but I'm
not sure the right way for greenstone's apache to set up its
environment (shouldn't it be doing this on its own anyway?)
--
Matt Bailey
(720) 255-1141
Senior Software Specialist
University of Denver, UTS
http://du.edu
http://system42.net