Re: [greenstone-users] Problems with setting up Apache webserver forGreenstone- Urgent

From Michael Dewsnip
DateTue, 28 Sep 2004 11:07:55 +1200
Subject Re: [greenstone-users] Problems with setting up Apache webserver forGreenstone- Urgent
In-Reply-To (Pine-LNX-4-44-0409271256540-20871-100000-fornax-it-iitb-ac-in)
Hi,

Just to confirm: you should have the Alias directive *after* ScriptAlias. Don't
forget you need to shut down and start up Apache whenever you change its
configuration files.

- Check again that you've entered everything correctly into the Apache httpd.conf
file
- Check that the gsdlhome value in gsdl/cgi-bin/gsdlsite.cfg is set correctly
- Check that the httpprefix value in gsdl/cgi-bin/gsdlsite.cfg is set to "/gsdl"
- Check that you can see the Apache page by going to
http://<your-computer-name>:8080/
- Check that you can see the contents of the gsdl directory by going to
http://<your-computer-name>:8080/gsdl
- Check that you get a "Forbidden" page when you go to
http://<your-computer-name>:8080/gsdl/cgi-bin
- Check that you can see Greenstone when you go to
http://<your-computer-name>:8080/gsdl/cgi-bin/library

If you still can't get it to work, send me personally your gsdlsite.cfg and
httpd.conf files and I'll have a look at them.

Regards,

Michael

Chaitra Rao wrote:

> Thanx Michael. But we have placed the Alias and Script ALias in the right
> order as mentioned in the installation notes. Please help soon since this
> is taking a lot of time.
> Thanx in advance! :)
>
> Regards,
> Chaitra
>
> On Tue, 21 Sep 2004, Michael Dewsnip wrote:
>
> > Hi,
> >
> > > Thanx Michael. But the problem was the order in which i had placed the
> > > Alias and ScriptAlias configs in the httpd.conf file. I had'nt placed
> > > Alias before ScriptAlias.Thanx for replying so quickly. It works fine now
> > > without the .exe,but when i installed the web library on Linux,it gave
> > > some garbage values when we type
> > > http://localhost:8080/gsdl/cgi-bin/library.
> >
> > If you're seeing garbage values it usually means you haven't got Alias and
> > ScriptAlias in the correct order. Try switching them.
> >
> > Also, try replacing "localhost" with the name of the server computer. For
> > example, I use "http://bedrock:8080/gsdl/cgi-bin/library", since bedrock is the
> > name of my computer.
> >
> > Regards,
> >
> > Michael
> >
> >