RE: [greenstone-users] building from command line vs. from GLI-problem

From Anant Sabane
DateMon, 3 Jan 2005 10:04:40 +0530
Subject RE: [greenstone-users] building from command line vs. from GLI-problem
In-Reply-To (41903483-A164EF3-cs-waikato-ac-nz)
These days, I am not receiving any mails from the group. Can any1 help
me with this?

Thanks and best regards
Anant Sabane

-----Original Message-----
From: greenstone-users-bounces@list.scms.waikato.ac.nz
[mailto:greenstone-users-bounces@list.scms.waikato.ac.nz] On Behalf Of
Michael Dewsnip
Sent: Tuesday, November 09, 2004 8:38 AM
To: richrobinson@gtcinternet.com
Cc: greenstone-users@list.scms.waikato.ac.nz
Subject: Re: [greenstone-users] building from command line vs. from
GLI-problem

Hi Rich,

That's odd, because the GLI is meant to add a unique timestamp to
collection URLs
to prevent these browser cache issues... but you need to click the
Preview
Collection button (you can't just switch to your browser and reload the
page). Is
this timestamp present in your page URLs?

Regards,

Michael

richrobinson@gtcinternet.com wrote:

> Michael,
>
> After trying your suggestion, seems it turned out to be a browser
cache issue -
> I need to clear the cache and restart the browser to see the HTML when
building
> from the GLI - don't need to when building from the command line.
Didn't
> recall this problem in 2.51, it's a bit annoying :)
>
> Rich
>
> At 1:32 PM +1300 11/8/04, Michael Dewsnip wrote:
> Hi Rich,
>
> Hmmm... that sounds like a nasty one. Building from the GLI should be
no
> different
> from building from the command-line, because all it does is run the
same Perl
> scripts. However, the GLI does provide a few extra arguments to
import.pl and
> buildcol.pl, so it actually runs:
>
> perl -S import.pl -gli -language [lang] -collect_dir [collectdir]
> [collectionname]
> perl -S buildcol.pl -gli -language [lang] -collect_dir
[collectdir]
> [collectionname]
>
> I can't imagine adding these options would cause the HTML version to
break, but
> you
> should try adding them at the command-line just in case. You should
also try
> building the collection in the GLI in Expert mode, and setting the
verbosity
> option
> to 3 to see if there are any errors.
>
> Regarding your second question, the GLI does not cache anything from
the
> collect.cfg file. You can change it as you wish and the GLI should
deal with it
> correctly when you next open the collection.
>
> Regards,
>
> Michael
>
> richrobinson@gtcinternet.com wrote:
>
> > Hi,
> >
> > I have recently experimented with running the import/build from the
commmand
> > line and am noticing something very interesting (this is in the 2.52
version).
> > The collection consists of Microsoft Word documents. When I do the
> import/build
> > with the GLI, it says it is converting them to HTML and the icons
for both
> Word
> > and HTML show up when previewed. But clicking on the HTML icon
shows no text,
> > though if there is a cover image that shows up.
> >
> > Meanwhile, doing the same thing from the command line, the HTML
version shows
> up
> > just fine. I have not altered the config file between doing it one
way and
> > another, at least not intentionally! Any ideas on what's happening?
> >
> > My commands with the manual method are simply:
> > perl -S import.pl [collectionname]
> > and
> > perl -S buildcol.pl [collectionname]
> > followed by a manual drag of the "building" directory contents into
"index".
> >
> > A second query is this - if I choose to go the manual route for a
while and
> > change the config file in the process, then choose to try the GLI
again - is
> > there a way to make the GLI recognize the new changes in the config
file or
> > will it default to the last way it was used?
> >
> > Regards,
> > Rich
>
> _______________________________________________
> greenstone-users mailing list
> greenstone-users@list.scms.waikato.ac.nz
> https://list.scms.waikato.ac.nz/mailman/listinfo/greenstone-users


_______________________________________________
greenstone-users mailing list
greenstone-users@list.scms.waikato.ac.nz
https://list.scms.waikato.ac.nz/mailman/listinfo/greenstone-users