Re: [greenstone-users] GLI Applet - Collection cannot be opened

From Michael Dewsnip
DateThu, 24 Aug 2006 16:24:10 +1200
Subject Re: [greenstone-users] GLI Applet - Collection cannot be opened
In-Reply-To (96e0484d0608221144m53717dd9ncec404acdaeec279-mail-gmail-com)
Hi Galvin,

Please check that the "gsdlhome" entry of the C:Program
FilesGreenstonecgi-bingsdlsite.cfg file (on the server) is correct.
Can you access Greenstone successfully from your web browser?

Regards,

Michael

Galvin Clancey wrote:

> I don't think I've made my problem very clear:
>
> I have installed the web server version on one computer (server) and
> have setup the GLI applet for off-site access. When I try to use the
> GLI applet to login to the server from any computer, I get the error I
> described. I just tried now to create a new collection using the GLI
> applet, and I got a similar error:
>
> An error has occurred on the remote Greenstone server while performing
> this operation:
> Collection <name> does not exist.
>
> Yes, the username on this computer is User1. I cannot find a .col file
> on the client computer, only on the server computer in the expected
> location (c:Program FilesGreenstone. . .).
>
> I have an existing collection on the server, and the only thing I want
> to do is remotely add/edit entries in that collection.
>
>
> Galvin
>
>
>
> On 8/21/06, * Katherine Don* <kjdon@cs.waikato.ac.nz
> <mailto:kjdon@cs.waikato.ac.nz>> wrote:
>
> Hi Galvin
>
> Now I have just reread the first sentence, and you are trying to
> use the
> applet version??
> If you are using the applet or gli client then it will save locally
> parts of the collection in C:Documents and
> Settings<username>Application DataGreenstoneGLIcollect.
>
> Try creating a new collection - does this work??
> Is your username User1??
> Maybe the gli is getting this wrong somehow.
>
> Regards,
> Katherine
>
> Galvin Clancey wrote:
> > I setup the GLI applet today, and everything was going smoothly
> until it
> > was completely installed. When I open the client-gli.bat file, the
> > Librarian opens up properly. I tell it to open my collection (it
> doesn't
> > work with both my collection and the demo collection) and I get the
> > following error:
> >
> > The collection at:
> > C:Documents and SettingsUser1Application
> > DataGreenstoneGLIcollectdemodemo.col
> > cannot be opened.
> >
> > I'm not sure why the GLI is looking in the directory because it
> doesn't
> > exist. My collections are saved in the C:Program
> > FilesGreenstonecollect directory, and I don't know what to do
> about
> > this. Even though it gives me an error, I still have read and write
> > capabilities with the collection through the Gather tab, but I
> cannot
> > use the Enrich, Design, or Create tabs.
> >
> > Any help would be greatly appreciated.
> >
> > Galvin Clancey
> >
> >
> >
> ------------------------------------------------------------------------
> >
> > _______________________________________________
> > greenstone-users mailing list
> > greenstone-users@list.scms.waikato.ac.nz
> <mailto:greenstone-users@list.scms.waikato.ac.nz>
> >
> https://list.scms.waikato.ac.nz/mailman/listinfo/greenstone-users
> <https://list.scms.waikato.ac.nz/mailman/listinfo/greenstone-users>
>
>
>------------------------------------------------------------------------
>
>_______________________________________________
>greenstone-users mailing list
>greenstone-users@list.scms.waikato.ac.nz
>https://list.scms.waikato.ac.nz/mailman/listinfo/greenstone-users
>
>