[greenstone-users] doc::add_utf8_metadata: warning: 'gsdlassocfile' wasn't utf8

From Renate Morgenstern
DateSat, 26 Aug 2006 00:13:33 +0100
Subject [greenstone-users] doc::add_utf8_metadata: warning: 'gsdlassocfile' wasn't utf8
In-Reply-To (200608250511-k7P5BL3Y002695-venus-namweb-com-na)


<<attachment>>
Type:
Filename:


<<attachment>>
Type: text/plain

Hi Michael,

These are JPG files and in the metadata I have German Umlaute (ä, ö, etc.)
The error message is only coming up in those
images where these characters appear in the dc.Title.
I have changed the input and default encodings to
various options, but I sill get this message.
Below is part of the log file - you can see that
it only occurs where the title contains diacritics.
In the A-Z Compact lists on the display the
diacritics are displayed as follows:
<http://localhost:1025/gsdl?e=d-0-00-damals--00-1-0--0prompt-10---4------0-1l--1-en-50---20-about---00031-001-1-0utfZz-8-00&a=d&c=damals&cl=CL3.6>
open this section of the library and view contents
Günter Göttling (1) (should be Günter Götttling)

What input and default encoding should I use?
Thanks
Renate
=============================

import.pl> RecPlug: getting directory C:Program
FilesGreenstonecollectdamalsimport
import.pl> RecPlug: found metadata in C:Program
FilesGreenstonecollectdamalsimportmetadata.xml
import.pl> RecPlug: getting directory C:Program
FilesGreenstonecollectdamalsimport1800 bis 1916
import.pl> RecPlug: found metadata in C:Program
FilesGreenstonecollectdamalsimport1800 bis 1916metadata.xml
import.pl> ImagePlug processing 1800 bis
19160001 Alter Baaiweg nach L?deritzbucht.jpg
import.pl> util::hard_link: unable to create hard
link. Attempting to copy file: C:Program
FilesGreenstonecollectdamalsimport1800 bis
19160001 Alter Baaiweg nach L?deritzbucht.jpg ->
C:Program
FilesGreenstonecollectdamalsarchivesHASH018a.dir0001
Alter Baaiweg nach L?deritzbucht.jpg
import.pl> doc::add_utf8_metadata: warning: 'gsdlassocfile' wasn't utf8
import.pl> ImagePlug processing 1800 bis 19160002 Ariam, Dammanlage.jpg
import.pl> ImagePlug processing 1800 bis 19160003 Aris, Bahnstation.jpg
import.pl> ImagePlug processing 1800 bis 19160004 Aus, Bahnhofshotel.jpg
import.pl> ImagePlug processing 1800 bis 19160005 Aus, Bahnhofshotel.jpg
import.pl> ImagePlug processing 1800 bis 19160006 Aus, Eisenbahn.jpg
import.pl> ImagePlug processing 1800 bis
19160007 Aus, Fliegermontage, 1914-15.jpg
import.pl> ImagePlug processing 1800 bis 19160008 Aus, Pferdest?lle.jpg
import.pl> util::hard_link: unable to create hard
link. Attempting to copy file: C:Program
FilesGreenstonecollectdamalsimport1800 bis
19160008 Aus, Pferdest?lle.jpg -> C:Program
FilesGreenstonecollectdamalsarchivesHASH016f.dir0008
Aus, Pferdest?lle.jpg
import.pl> doc::add_utf8_metadata: warning: 'gsdlassocfile' wasn't utf8


> 6. Re: Error message:doc::add_utf8_metadata: warning:
> 'gsdlassocfile' wasn't utf8 (Michael Dewsnip)
>
>Message: 6
>Date: Fri, 25 Aug 2006 15:25:21 +1200
>From: Michael Dewsnip <mdewsnip@cs.waikato.ac.nz>
>Subject: Re: [greenstone-users] Error message:doc::add_utf8_metadata:
> warning: 'gsdlassocfile' wasn't utf8
>To: Renate Morgenstern <rmorgenstern@unam.na>
>Cc: greenstone-users@list.scms.waikato.ac.nz
>Message-ID: <44EE6DA1.6010402@cs.waikato.ac.nz>
>Content-Type: text/plain; charset=us-ascii
>
>Hi Renate,
>
>Are you including files with non-Latin characters in their names?
>Perhaps you could send me an example file that has the problem and I'll
>try it here.
>
>Regards,
>
>Michael
>
>
>
>Renate Morgenstern wrote:
>
> > Good day,
> >
> > I want to build a collection of historical photos, and when the
> > collection is imported I get the following error message, and I do not
> > know what should be changed.
> > doc::add_utf8_metadata: warning: 'gsdlassocfile' wasn't utf8
> > After the collection has been built it look fine, but there are some
> > images which do not open when I click on the thumbnail.
> > Thanks in advance for the help.
> >
> > Renate
> >
> >
> >
> > Mrs. Renate Morgenstern
> > University of Namibia Library
> > Head: Technical Services and Systems
> > Private Bag 13301, Windhoek, Namibia
> > Tel: +264 61 2063869; Fax: +264 61 242124
> > email: rmorgenstern@unam.na
> > http://www.unam.na/ilrc/library/index.html
> >
> >
> >
> >
> > _______________________________________________
> > greenstone-users mailing list
> > greenstone-users@list.scms.waikato.ac.nz
> > https://list.scms.waikato.ac.nz/mailman/listinfo/greenstone-users
> >
> >
>
>
>
>
>------------------------------
>
>Message: 7
>Date: Fri, 25 Aug 2006 15:50:13 +1200
>From: Michael Dewsnip <mdewsnip@cs.waikato.ac.nz>
>Subject: Re: [greenstone-users] GLI Applet - Collection cannot be
> opened
>To: Galvin Clancey <galvin.clancey@gmail.com>
>Cc: greenstone-users@list.scms.waikato.ac.nz
>Message-ID: <44EE7375.5080803@cs.waikato.ac.nz>
>Content-Type: text/plain; charset=ISO-8859-1
>
>Hi Galvin,
>
>OK, let's start from the beginning.
>
>- You're using Greenstone v2.70w, correct?
>
>- Are you using Apache or IIS?
>
>- Please start with the GLI client (ie. client-gli.bat). The GLI applet
>adds another layer of complexity that we don't need while debugging this
>problem.
>
>- Choose File -> Open. You're asked for your username and password, then
>do you get a list of collections?
>
>- The collection files should be in C:Documents and
>Settings<Username>Application DataGreenstoneGLIcollect. The
>"Application Data" folder is usually hidden, so make sure your Explorer
>is set to show hidden files.
>
>- Are there any errors showing in the client-gli.bat DOS prompt?
>
>Regards,
>
>Michael
>
>
>
>Galvin Clancey wrote:
>
> > Yes, I can access Greenstone using the web browsers of various
> > computers. The gsdlhome entry in gsdlsite.cfg points to C:Program
> > FilesGreenstone, which I assume is correct.
> >
> > Galvin
> >
> > On 8/23/06, *Michael Dewsnip* <mdewsnip@cs.waikato.ac.nz
> > <mailto:mdewsnip@cs.waikato.ac.nz>> wrote:
> >
> > Hi Galvin,
> >
> > Please check that the "gsdlhome" entry of the C:Program
> > FilesGreenstonecgi-bingsdlsite.cfg file (on the server) is correct.
> > Can you access Greenstone successfully from your web browser?
> >
> > Regards,
> >
> > Michael
> >
> >
> >
> > Galvin Clancey wrote:
> >
> > > I don't think I've made my problem very clear:
> > >
> > > I have installed the web server version on one computer (server) and
> > > have setup the GLI applet for off-site access. When I try to use
> > the
> > > GLI applet to login to the server from any computer, I get the
> > error I
> > > described. I just tried now to create a new collection using the GLI
> > > applet, and I got a similar error:
> > >
> > > An error has occurred on the remote Greenstone server while
> > performing
> > > this operation:
> > > Collection <name> does not exist.
> > >
> > > Yes, the username on this computer is User1. I cannot find a
> > .col file
> > > on the client computer, only on the server computer in the expected
> > > location (c:Program FilesGreenstone. . .).
> > >
> > > I have an existing collection on the server, and the only thing
> > I want
> > > to do is remotely add/edit entries in that collection.
> > >
> > >
> > > Galvin
> > >
> > >
> > >
> > > On 8/21/06, * Katherine Don* <kjdon@cs.waikato.ac.nz
> > <mailto:kjdon@cs.waikato.ac.nz>
> > > <mailto:kjdon@cs.waikato.ac.nz <mailto:kjdon@cs.waikato.ac.nz>>>
> > wrote:
> > >
> > > Hi Galvin
> > >
> > > Now I have just reread the first sentence, and you are trying to
> > > use the
> > > applet version??
> > > If you are using the applet or gli client then it will save
> > locally
> > > parts of the collection in C:Documents and
> > > Settings<username>Application DataGreenstoneGLIcollect.
> > >
> > > Try creating a new collection - does this work??
> > > Is your username User1??
> > > Maybe the gli is getting this wrong somehow.
> > >
> > > Regards,
> > > Katherine
> > >
> > > Galvin Clancey wrote:
> > > > I setup the GLI applet today, and everything was going
> > smoothly
> > > until it
> > > > was completely installed. When I open the client-gli.bat
> > file, the
> > > > Librarian opens up properly. I tell it to open my
> > collection (it
> > > doesn't
> > > > work with both my collection and the demo collection) and
> > I get the
> > > > following error:
> > > >
> > > > The collection at:
> > > > C:Documents and SettingsUser1Application
> > > > DataGreenstoneGLIcollectdemodemo.col
> > > > cannot be opened.
> > > >
> > > > I'm not sure why the GLI is looking in the directory
> > because it
> > > doesn't
> > > > exist. My collections are saved in the C:Program
> > > > FilesGreenstonecollect directory, and I don't know what
> > to do
> > > about
> > > > this. Even though it gives me an error, I still have read
> > and write
> > > > capabilities with the collection through the Gather tab, but I
> > > cannot
> > > > use the Enrich, Design, or Create tabs.
> > > >
> > > > Any help would be greatly appreciated.
> > > >
> > > > Galvin Clancey
> > > >
> > > >
> > > >
> > >
> >
> ------------------------------------------------------------------------
> >
> > > >
> > > > _______________________________________________
> > > > greenstone-users mailing list
> > > > greenstone-users@list.scms.waikato.ac.nz
> > <mailto:greenstone-users@list.scms.waikato.ac.nz>
> > >
> <mailto:greenstone-users@list.scms.waikato.ac.nz>
> <mailto:greenstone-users@list.scms.waikato.ac.nz>>
> > > >
> > >
> > https://list.scms.waikato.ac.nz/mailman/listinfo/greenstone-users
> > >
> >
> <https://list.scms.waikato.ac.nz/mailman/listinfo/greenstone-users>
> <https://list.scms.waikato.ac.nz/mailman/listinfo/greenstone-users>>
> > >
> > >
> >
> >------------------------------------------------------------------------
> > >
> > >_______________________________________________
> > >greenstone-users mailing list
> > > greenstone-users@list.scms.waikato.ac.nz
> > <mailto:greenstone-users@list.scms.waikato.ac.nz>
> > >https://list.scms.waikato.ac.nz/mailman/listinfo/greenstone-users
> > >
> > >
> >
> >
>
>
>
>
>------------------------------
>
>Message: 8
>Date: Fri, 25 Aug 2006 17:06:45 +1200
>From: Katherine Don <kjdon@cs.waikato.ac.nz>
>Subject: Re: [greenstone-users] Display a range of date (yyyy-yyyy) in
> dc.date meta
>To: ruben pandolfi <pandolfi.r@inwind.it>
>Cc: greenstone-users@list.scms.waikato.ac.nz
>Message-ID: <44EE8565.30002@cs.waikato.ac.nz>
>Content-Type: text/plain; charset=us-ascii
>
>Hi Ruben and list,
>
>I have just modified the code so that [Date] outputs the raw date, while
>[format:Date] outputs the pretty version.
>The date format accepted for DateList and date formatting is now
>yyyymmdd or yyyy-mm-dd.
>[format:Date] uses a macro day _textmonthmonth_ year so the
>formatting can be easily changed in macro files.
>
>For your situation (e.g. 2001-2003) the formatting won't work, but at
>least you'll be able to output the Date without it getting mucked up.
>
>This will be available in the next release, coming soon...
>
>Regards,
>Katherine
>
>Katherine Don wrote:
> > Hi Ruben
> >
> > Is your problem that when greenstone comes to display the metadata, it
> > formats it strangley?
> > Currently the code will try to turn any Date metadata into a pretty
> > format, eg 20060102 will be displayed as 2 January 2006
> > Obviously, this doesn't work if the date is not in that format.
> > One of the things we need to do is to make this formatting optional.
> >
> > In the meantime, you have two options.
> > 1. Edit the source code and either turn off the special formatting or
> > make it handle your format. The formatting code is format_date() in
> > src/recpt/formattools.cpp.
> >
> > 2. Use a different metadata element for your Dates. Something that is
> > not xx.Date.
> >
> > I'll try and add something for the next release so that you can display
> > the raw value if you want to.
> >
> > Regards,
> > Katherine
> >
> > ruben pandolfi wrote:
> >
> >>Hi All,
> >>
> >>I would like to display more than one date in dc.date.
> >>
> >>At the moment it does not work, as I think the metadata
> >>
> >>dc.date
> >>
> >>only accept one value.
> >>
> >>Would it be possible to display two values in dc.date field?
> >>
> >>This is to display a document date range:
> >>
> >>title: mytitile collection
> >>author: thisauthor
> >>date: 1900-1920
> >>
> >>meaning that this document refers to the years from 1900 to 1920
> >>
> >>Is there a way to achieve this without making date field repeatable?
> >>
> >>Thank you,
> >>
> >>Ruben
> >>
> >>_______________________________________________
> >>greenstone-users mailing list
> >>greenstone-users@list.scms.waikato.ac.nz
> >>https://list.scms.waikato.ac.nz/mailman/listinfo/greenstone-users
> >>
> >>
> >
> >
> > _______________________________________________
> > greenstone-users mailing list
> > greenstone-users@list.scms.waikato.ac.nz
> > https://list.scms.waikato.ac.nz/mailman/listinfo/greenstone-users
> >
> >
>
>
>
>------------------------------
>
>_______________________________________________
>greenstone-users mailing list
>greenstone-users@list.scms.waikato.ac.nz
>https://list.scms.waikato.ac.nz/mailman/listinfo/greenstone-users
>
>
>End of greenstone-users Digest, Vol 41, Issue 29
>************************************************
>
>
>
>
>--
>No virus found in this incoming message.
>Checked by AVG Free Edition.
>Version: 7.1.405 / Virus Database: 268.11.5/425 - Release Date: 8/22/2006

Mrs. Renate Morgenstern
P O Box 30664, Windhoek
Tel/Fax: 242124 (H); 2063869 (W)
University of Namibia Library
Head: Technical Services and Systems
Private Bag 13301, Windhoek, Namibia
http://www.cds-isis.org.na
http://www.unam.na/ilrc/library/index.html


<<attachment>>
Type: text/html

Hi Michael,

These are JPG files and in the metadata I have German Umlaute (ä, ö, etc.)
The error message is only coming up in those images where these characters appear in the dc.Title.
I have changed the input and default encodings to various options, but I sill get this message.
Below is part of the log file - you can see that it only occurs where the title contains diacritics.
In the A-Z Compact lists on the display the diacritics are displayed as follows:
download


<<attachment>>
Type: text/plain

No virus found in this outgoing message.
Checked by AVG Free Edition.
Version: 7.1.405 / Virus Database: 268.11.6/428 - Release Date: 8/25/2006