[greenstone-devel] Re: About running the demo-client application

From Anupama of Greenstone Team
DateTue Jun 17 11:52:59 2008
Subject [greenstone-devel] Re: About running the demo-client application
In-Reply-To (48569761-5060903-cis-strath-ac-uk)
Hi again,

Please see the previous email I sent to you today first.

I just tried out both the latest version of the democlient checked out
from SVN and the zipped version of the client from the svn page (as
indicated in your document). I tested it against the 10 June 2008
Greenstone 3 installation which is the same as the one you have. In my
case both democlient instances were able to connect to the Greenstone 3
QBRSOAPServerlocalsite web services deployed.

The first exception you encountered was "Unknownhostexception" which
would mean that the URL contained a host that wasn't recognised. That
doesn't make sense though as your GS3 at localhost was displayed in the
browser in your screen captures. I would still try finding out the
computer name (hostname) and using that instead of localhost to see
whether it may help.

The screen captures show that the second Exception thrown is a
MalformedURLException which would be that the URL is invalid.

Try pasting whatever URL you put into the edit box into a browser and
load the page. This may help track down anything that's hard to see on
first sight, although by inspecting your screen captures what you typed
looks right to me.

Tell me how it turns out after trying out the suggestions in the
previous email and this one.

Good luck,
Anupama


Suthanya Doung-In wrote:
> Dear Anupama,
>
> I do following the steps as your suggestion from the previous
> email. Many thanks again. Finally, I can install ant and start ant
> successful:-).
>
> After that, i download and install demo-client application
> including running gs3demockient.bat. However, when the page of
> application start, I choose greenstone in combo box and enter the wsdl
> file of the QBRSOAPServer web services into dialog box. It has error. I
> think I do correctly but I wonder about this error. Tomcat still
> running. So i can?t use search and browse services. Now I did not try
> on Fedora and I will try tonight and see about the result and let you know.
>
>
> I sent the file that I capture the screens (step by step) about run
> the demo-client application . Please find the attached file.
>
> Many thanks in advance.
>
> Best Wishes,
> Suthanya Doung-in