Re: [greenstone-users] Help installing 2.72 on Apache

From Michael Dewsnip
DateThu, 25 Jan 2007 11:51:04 +1300
Subject Re: [greenstone-users] Help installing 2.72 on Apache
In-Reply-To (OFAAECD717-CE644310-ONC125726D-003217A7-C125726D-003250E3-unog-un-org)
Hi,

Please follow the instructions at
http://www.cs.waikato.ac.nz/~mdewsnip/greenstone/remote-greenstone.html.

Regards,

Michael

Susana.Olivares@unctad.org wrote:

>
>
>
> Hello, all
>
> We are trying to install version 2.27 of Greenstone on our Apache
> server (Suse 10.1, JRE 1.4.2).
>
> On running the linux install, we get the following error:
>
> *./setupLinux.bin*
>
> * Initializing InstallShield Wizard........*
>
> * Initializing InstallShield Wizard........*
> * Launching InstallShield Wizard........*
>
>
> *The wizard cannot continue because of the following error: could not
> load wizard specified in /wizard.inf (104)*
>
> So we run the unix pack, and it installs, but the gli does not want to
> run. We get the following:
>
> /Unix/Install.sh
>
> =======================================================
> * ./gli.sh*
>
> *Greenstone Librarian Interface (GLI)*
> *Copyright (C) 2006, New Zealand Digital Library Project, University
> Of Waikato*
> *GLI comes with ABSOLUTELY NO WARRANTY; for details see LICENSE.txt*
> *This is free software, and you are welcome to redistribute it*
>
> *Checking GSDL: /usr/local/gsdl*
> *Your environment has successfully been set up to run Greenstone*
> *Checking Perl: /usr/bin/perl*
> *Checking Java: /usr/lib/jvm/jre/bin/java*
>
> *Running the Greenstone Librarian Interface...*
> *Warning: -Xmx128M not understood. Ignoring.*
>
> *(.:2577): Gtk-WARNING **: cannot open display:*
> *Done!*
>
> So we try magegli.sh, and we get:
>
> *./makegli.sh*
>
> *Greenstone Librarian Interface (GLI)*
> *Copyright (C) 2006, New Zealand Digital Library Project, University
> Of Waikato*
> *GLI comes with ABSOLUTELY NO WARRANTY; for details see LICENSE.txt*
> *This is free software, and you are welcome to redistribute it*
>
> *Checking Javac: /usr/lib/jvm/jre/bin/javac*
>
> *Failed to locate an appropriate version of Javac. You must install a*
> *Java Development Kit (version 1.4 or greater) before compiling the*
> *Greenstone Librarian Interface.*
>
>
> We have installed JDK 1.4.2, and now it seems to run makegli.sh, but
> when we go to the library interface on the browser, nothing happens.
> So we enabled the gliapplet on main.cfg, and we get the jre plug-in,
> but broken.
>
> What can we try now?
>
>
> Thanks in advance for the help!
>
> Susana Olivares
> Virtual Institute
> UNCTAD - United Nations Conference on Trade and Development
> Palais des Nations
> 1211 Geneva 10 - Switzerland
> Phone: +41 22 917 5823 Fax: +41-22 917 0050
> Web: http://vi.unctad.org
>
>------------------------------------------------------------------------
>
>_______________________________________________
>greenstone-users mailing list
>greenstone-users@list.scms.waikato.ac.nz
>https://list.scms.waikato.ac.nz/mailman/listinfo/greenstone-users
>
>