Re: Fwd: [greenstone-users] UnSupportedClassVersion exception when running GLI using 2.74

From Oran Fry
DateMon, 13 Aug 2007 09:39:50 +1200
Subject Re: Fwd: [greenstone-users] UnSupportedClassVersion exception when running GLI using 2.74
In-Reply-To (919149-14406-qm-web33806-mail-mud-yahoo-com)
Hi sripathi raja rao,

GLI in Greenstone2.74 was compiled with javac v1.4.2.08, so the solution would be to upgrade to this java version or better.

Kind Regards,
Oran Fry.

sripathi raja rao wrote:
Hi List,

Did anyone had a chance to look at the reason for the
UnSupportedClassVersion exception when trying to run
the GLI? I did go through some of the forums on Sun
website and such an exception is attributed to the
difference in the Java(JDK) version that was used to
compile the java source code in the new version 2.74.

This is what I got when I executed java -version at
the command prompt.

java version "1.4.2_04"
Java(TM) 2 Runtime Environment, Standard Edition
(build 1.4.2_04-b05)
Java HotSpot(TM) Client VM (build 1.4.2_04-b05, mixed
mode)

Any pointers??

Regards
Raja


      5, 50, 500, 5000 - Store unlimited mails in your inbox. Go to http://help.yahoo.com/l/in/yahoo/mail/yahoomail/tools/tools-08.html



Subject:
[greenstone-users] UnSupportedClassVersion exception when running GLI using 2.74
From:
sripathi raja rao <s_raja_rao@yahoo.com>
Date:
Thu, 9 Aug 2007 11:52:58 +0100 (BST)
To:
greenstone-users@list.scms.waikato.ac.nz
To:
greenstone-users@list.scms.waikato.ac.nz

Hello,

I have recently downloaded the Greenstone version 2.74
onto my Windows XP Machine and am running it in web
library mode.

I am having a problem when I am trying to invoke
Greenstone Librarian Interface and the error that I am
encountering is below. Could you please let me know
what might be going wrong ? I have version 2.73 on the
same system running in the local library mode and the
JDK version is the same for both 2.73 & 2.74.

C:Greenstonegli>gli.bat

Greenstone Librarian Interface (GLI)
Copyright (C) 2006, New Zealand Digital Library
Project, University Of Waikato
GLI comes with ABSOLUTELY NO WARRANTY; for details see
LICENSE.txt
This is free software, and you are welcome to
redistribute it

Checking GSDL: C:Greenstone
Checking Perl: C:Greenstonebinwindowsperlbin
Checking Java: C:RajaRaobea3jdk142_04bin

Running the Greenstone Librarian Interface...
Exception in thread "main"
java.lang.UnsupportedClassVersionError:
org/greenstone/gatherer/Gatherer
rog (Unsupported major.minor version 49.0)
        at java.lang.ClassLoader.defineClass0(Native
Method)
        at
java.lang.ClassLoader.defineClass(ClassLoader.java:537)
        at
java.security.SecureClassLoader.defineClass(SecureClassLoader.java:123)
        at
java.net.URLClassLoader.defineClass(URLClassLoader.java:251)
        at
java.net.URLClassLoader.access$100(URLClassLoader.java:55)
        at
java.net.URLClassLoader$1.run(URLClassLoader.java:194)
        at
java.security.AccessController.doPrivileged(Native
Method)
        at
java.net.URLClassLoader.findClass(URLClassLoader.java:187)
        at
java.lang.ClassLoader.loadClass(ClassLoader.java:289)
        at
sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:274)
        at
java.lang.ClassLoader.loadClass(ClassLoader.java:235)
        at
java.lang.ClassLoader.loadClassInternal(ClassLoader.java:302)

Regards
Raja


      Try the revolutionary next-gen Yahoo! Mail. Go to http://mrd.mail.yahoo.com/dc/landing

_______________________________________________
greenstone-users mailing list
greenstone-users@list.scms.waikato.ac.nz
https://list.scms.waikato.ac.nz/mailman/listinfo/greenstone-users
  

_______________________________________________ greenstone-users mailing list greenstone-users@list.scms.waikato.ac.nz https://list.scms.waikato.ac.nz/mailman/listinfo/greenstone-users