Re: [greenstone-users] OSX - ImageMagick installed but Greenstone can't locate

From Rich Robinson
DateThu, 26 May 2005 08:43:50 -0700
Subject Re: [greenstone-users] OSX - ImageMagick installed but Greenstone can't locate
Two responses here to emails from John and Michael:

************
Trying to set the path in bash gives error "export: command not
found" in fact that happens whenever I open the bash shell - I'm
wondering if there was some kind of less than full implementation of
bash in OS 10.2.8 - anyone know if an upgrade to Jaguar and higher
would help?

> Well, I set the $PATH in the tcsh shell; then switched to the bash
> shell just now and saw the path is different, so must get set
> separately for each shell....in that case how would I get a regular
> application to look on a particular shell's path? Otherwise I'll
> modify the import.pl as you suggested.

bash looks in $HOME/.profile, tcsh will look in $HOME/.cshrc.
They both use a different syntax... bash has
PATH=.....
while tcsh has
setenv PATH ....

tcsh used to be the default terminal shell in older versions of OS X,
but apple have come to their senses and are now defaulting to
a "sh-compatible" shell, bash. It was suggested to me that modifying the
path in $HOME/.profile would affect all applications after you next log
in, but I can't confirm that this is the case.

John
************
Second in response to Michael -

Yes, it's giving Perl errors alright as follows -
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LC_ALL = (unset),
LANG = "en_US"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
dyld: perl Undefined symbols:
_Perl_safefree
_Perl_safemalloc
_Perl_saferealloc
_perl_call_method
_perl_call_pv
_perl_call_sv
_perl_get_hv
_perl_get_sv
(END)

I did the install by the book so to speak, but I guess I should try it again.

Hi Rich,

I imagine this is caused by the Perl errors you show in your next
e-mail, which seem to indicate that Perl isn't set up quite right on
your machine.

If you run "source setup.bash" in the Greenstone directory, then "perl
-S pluginfo.pl HTMLPlug" you should see a list of HTMLPlug's options.
I'm guessing you will see some errors from Perl instead.

Let me know what you find out,

Michael

Rich Robinson wrote:

> Michael,
>
> Trying to creat a new collection and it seems to stop at every plugin
> with the message "Unable to determine the arguments for the xxxxxxx
> plugin. Please ensure that the plugin in question provides the -xml
> flag by running the pluginfo.pl script..." What's happening here?
>
> Rich
>
>> Hi Rich,
>>
>> The GLI's test to see if ImageMagick is installed is fairly simple: it
>> just runs "identify -version". Assuming you can run this from a new
>> terminal and get a sensible result, this should work, but it could be
>> failing incorrectly for some reason.
>>
>> Try creating a new collection, adding an image, then building it. If
>> this succeeds then we'll know that everything is working apart from the
>> GLI test, otherwise we'll have to check your ImageMagick installation
>> further.
>>
>> All the best,
>>
>> Michael
>>
>>
>>
>> Rich Robinson wrote:
>>
>>> Hi,
>>> On OSX 10.2.8 I successfully installed ImageMagick 5.5.7, ran the
>>> standard test to be sure it works. However, Greenstone's GLI puts up
>>> the message that it can't locate ImageMagick. I've added the
>>> ImageMagick directory to my path variable as well as the usr/localbin
>>> directory that contains "convert".
>>>
>>> Any help on getting Greenstone to recognize IM would be welcome!
>>>
>>> Rich R.
>>>