[greenstone-users] Re: GLI not functioning with Ubuntu (Michael Dewsnip). #5 in greenstone-users Digest, Vol 48, Issue 35

From H.M. Gladney
DateThu, 29 Mar 2007 09:31:38 -0700
Subject [greenstone-users] Re: GLI not functioning with Ubuntu (Michael Dewsnip). #5 in greenstone-users Digest, Vol 48, Issue 35
In-Reply-To (460b33bd-4ac4e84e-67f4-ffff821dSMTPIN-ADDED-mx-google-com)

I had a similar problem to that reported by Bret Wiebe, and will presently report carefully what I saw and what I did to resolve it.  For the moment, let me suggest very briefly what I believe to have been the source of many problem symptoms and what solution worked for me.

I believe that the symptoms I saw, and that might include what Wiebe is seeing, originated in incomplete satisfaction of package dependencies in installing a suitable Java implementation.  Which particular unsatisfied dependency a user encounters will depend on which packages happened to be installed when he attempts to execute "./gli.sh".  In Wiebe's case, it seems to have been Perl.  I believe that Java packages depend on Perl.

I believe that Greenstone GLI is specifically set to not work with GNU Java, perhaps because GNU Java is reputedly replete with bugs.  It is recommended that one instead install Sun Java and make that the default choice whenever other software calls for Java.  (Uninstalling the GNU Java version delivered as part of Ubuntu Linux risks causing other errors.)  Notwithstanding what some Web tutorials suggest, it would be imprudent to install Sun Java using RPM, or by converting Sun's ".rpm" package to a Debian package (".deb") in order to use the Debian installer.  Reason: these installers do not seem to resolve all dependencies.  A possible consequence is that, after such an installation (I tried each), you are likely to encounter other errors.  In my case, I was led astray by such errors--led to attempt to fix the specific errors seen, only to encounter another error.  (Sequential debugging--very tedious!) 

The Synaptic Package Manager (delivered as part of the Ubuntu distribution) is designed to detect package dependencies and to resolve them recursively.  I.e., if you use Synaptic to download and install package A, which happens to depend on package B which in turn depends on package C, Synaptic will handle all together any of A, B, and C that is not already installed on your system.

If you look at the default package list in Synaptic, you will not find Sun Java.  However, Sun Java is available via the Synaptic Package Manager if one sets Synaptic up with "Settings --> Repositories --> Non-free (Multiverse)" turned on.  Then it installs easily (including forcing the essential end user licence agreement), together with other packages.

Cheerio, Henry
 
H.M. Gladney, Ph.D.  http://home.pacbell.net/hgladney


-----Original Message-----
------------------------------

Message: 5
Date: Thu, 29 Mar 2007 15:14:53 +1200
From: Michael Dewsnip <mdewsnip@cs.waikato.ac.nz>
Subject: Re: [greenstone-users] GLI not functioning with Ubuntu
To: Bret Wiebe <bret@princerupertlibrary.ca>
Cc: greenstone-users@list.scms.waikato.ac.nz
Message-ID: <460B2F2D.8090002@cs.waikato.ac.nz>
Content-Type: text/plain; charset=ISO-8859-1

Hi Bret,

This is likely to be a problem with the Perl XML::Parser module. Try:

    cd /usr/local/gsdl
    source setup.bash
    pluginfo.pl -xml -listall

Do you get a lot of XML output, or errors?

Regards,

Michael
DL Consulting Ltd.



Bret Wiebe wrote:
> Hi,
>
> I've installed Greenstone v2.72 on a box running Ubuntu 5.10, kernel
> 2.6.12-10. It works great for accessing the demo collection over the
> web but the GLI is not working. There are basically two errors in
> functionality:   (1) when I try to open the demo collection the result
> is a message "The collection at: /usr/local/gsdl/collect/demo/demo.col
> cannot be opened." (2) when I then try to close GLI the cursor changes
> to 'please wait' mode and then nothing happens, I have to Ctrl-C in
> the terminal window to end the program.
>
> The computer is presently running Apache 2.0.54-5, perl 5.8.7 and jre 1.6.0  I have also tried using jre 1.4.2_13 but the same behaviour

> occurred. I think that the jre is working okay because the "Greenstone Editor for Metadata Sets" seems to work fine - I can open, edit and

> save files and then exit the app with no errors.
>
> The text from the console while running GLI is included below. Any suggestions on what else to check or how to rectify this would be

> greatly appreciated.
>
> Thanks,
> Bret Wiebe
> Prince Rupert Library
>
>
> running ./gli.sh produces the following:
>
> Greenstone Librarian Interface (GLI)
> Copyright (C) 2006, New Zealand Digital Library
> Project, University Of Waikato
> GLI comes with ABSOLUTELY NO WARRANTY; for details see
> LICENSE.txt
> This is free software, and you are welcome to
> redistribute it
>
> Checking GSDL: /usr/local/gsdl
> Your environment has successfully been set up to run
> Greenstone
> Checking Perl: /usr/bin/perl
> Checking Java: /usr/bin/java
>
> Running the Greenstone Librarian Interface...
> Version: v2.72
>
> SAX exception: The element type "PluginList" must be
> terminated by the matching end-tag "</PluginList>".
> org.xml.sax.SAXParseException: The element type
> "PluginList" must be terminated by the matching
> end-tag "</PluginList>".
>        at
> org.apache.xerces.framework.XMLParser.reportError(XMLParser.java:1196)
>        at
>