Re: [greenstone-users] "Go to page" Feature Doesn't Work

From Gavin Spomer
DateMon, 10 Sep 2007 09:48:48 -0700
Subject Re: [greenstone-users] "Go to page" Feature Doesn't Work
Okay, with help from Georges Braoudakis I found that removing the <PageGroup> and </PageGroup> tags from my xml based .item files allowed the "go to feature" to work. Strange solution, but it worked for me.

- Gavin

>>> Gavin Spomer <spomerg@cwu.EDU> 09/04/07 10:41 AM >>>
Thanks a bunch, Georges. I have dc.Title in my <Page> sections (instead of Title) and I removed them just to see if I'd have the same result as you, but it didn't work. You have however given me a lot to go on. Seems that the xml-based .item file has an affect on the "go to page" feature. Thanks again for sharing your discovery. It gives me a lot to work with and I'll post to the list if I figure the problem out.

Kind of strange that it doesn't work "out of the box". Even stranger that no one has mentioned it, to my knowledge. Ah, but that's the fun of open source! :)

- Gavin

>>> Georges Braoudakis <gbraouda@polydoc.net> 08/29/07 11:37 PM >>>
Hi Gavin,

I've exactly the same problem with my paged image document (10 pages), but
the "go to page feature" is now working after eliminating the "<Metadata name="Title">...</Metadata> in the <Page> sections of the .item xml file !

Link to my paged image document :

http://ks301053.kimsufi.com/gsdl/cgi-bin/library.exe?e=d-01000-00---off-0essai11--00-1--0-10-0---0---0prompt-10---4-------0-1l--11-fr-50---20-about---00-3-1-00-0-0-11-1-0utfZz-8-00&d=HASH17cf4cd57cf10d8b4604d5.1&cl=CL1&gp=4

Regards,
Georges Braoudakis

----- Original Message -----
From: "Gavin Spomer" <spomerg@cwu.EDU>
To: <greenstone-users@list.scms.waikato.ac.nz>
Sent: Thursday, August 30, 2007 12:46 AM
Subject: [greenstone-users] "Go to page" Feature Doesn't Work


I have a paged image collection I'm working on that the "go to page" feature
has never worked. For example I have one item that has a group of 50 paged
images. On the header page (or any other page) I type in "4" and click the
"go to page" button and it just stays at the current page instead of going
to page 4. The previous and next arrows work just fine however.

I looked at the page source, specifically at the html form that handles this
and it looks like it passes this argument with the gp argument: <input
type="text" name="gp" size="3" maxlength="4">, but Greenstone doesn't seem
to do anything with this.

Anyone else have the same problem? I searched through the list archives, but
couldn't find anything on this. Thanks for any help.

- Gavin


--------------------------------------------------------------------------------


_______________________________________________
greenstone-users mailing list
greenstone-users@list.scms.waikato.ac.nz
https://list.scms.waikato.ac.nz/mailman/listinfo/greenstone-users


_______________________________________________
greenstone-users mailing list
greenstone-users@list.scms.waikato.ac.nz
https://list.scms.waikato.ac.nz/mailman/listinfo/greenstone-users