Re: [greenstone-devel] wget not found

From Russell Sheptak
DateMon, 28 Feb 2005 12:34:00 -0800
Subject Re: [greenstone-devel] wget not found
In-Reply-To (BHFMVkGHGtWW-K2nK8wL5-mail-bigpond-com)
There's a bug in the code in gli's Utility.java in the 2.52 sources.
The author of the method that generates the path used to find the wget
utility assumed that both the macintosh and linux would look for
binaries in the $GSDLHOME/bin/linux directory. Of course it really
needs to be looking for wget in the $GSDLHOME/bin/darwin directory, as
shipped.

I can send you either a corrected GLI.jar to drop into you installation
(assuming you're not building from source) or a corrected Utility.java
if you want to rebuild GLI from source. Let me know which you want.

rus

On Feb 28, 2005, at 6:18 AM, stephen.degabrielle@bigpond.com wrote:

> Hi. I just downloaded the latest gs for os x 10.3.
> Unfortunately, the GLI reports that it can't find a suitable wget and
> is disabling the web page download.
>
> I have checked it is included-Which it is- and even changed gli.sh to
> point to it in the applications/Greenstone/bin/Darwin folder to no
> avail.
>
> Has anyone else had this problem? I'm [easily] stumped.
>
> Regards,
>
> Stephen
>
> --
> Stephen De Gabrielle
> 0404041209 sms/mms
>
>
> _______________________________________________
> greenstone-devel mailing list
> greenstone-devel@list.scms.waikato.ac.nz
> https://list.scms.waikato.ac.nz/mailman/listinfo/greenstone-devel
>
>
----------------------
Rus Sheptak rus@sonic.net